Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Error while Executing Perl script to generate headers



  • Hello guys,
    you know me, it's been a week that I struggled to install QFTP,
    i will go step by step and hope someone can help me
    1st Step : i downloaded the QFTP source from github (the file is qtftp-master)

    0_1562662525231_perldi.png
    2nd Step : i renamed the file "qtftp-master" to "qtftp"
    3rd Step : i open the project, i made execute qmake (it works ) i made a build, doestn't work , no such file or directory error (surely because of the perl sync.pl not executed yet )

    4th Step : i copy the qtftp source and paste it to my source version of qt ( C:\Qt\Qt5.3.0\5.3\Src\qtftp )

    0_1562662405031_perlda.png
    Now i have to execute the Perl script to generate the headers, i installed ActivePerl and open cmd

    0_1562662726493_cd.png
    when i tried to execute my script, eroor"Can't open perl script :No such file or direcory
    Why he can't execute the script while the directory exist and the file exist ?Thanks



  • @Zunneh Am I thinking so simple or are you really trying to execute a perl application that does not exits.
    The file you trying to execute, C:\Qt\Qt5.3.0\5.3\Src\qtftp\syncqt.pl
    The real file path, C:\Qt\Qt5.3.0\5.3\Src\qtftp\sync.pl
    Why do you write syncqt.pl?



  • @closx even i tried it it doesn't work , when i press enter nothing happen in console (
    no message ) , it should be like this
    0_1562664888882_5081f1a3-b8d0-413d-82fc-ef3ef8e74749-image.png



  • @Zunneh
    I wish you'd sort out your sync.pl versus syncqt.pl, but that's up to you.

    As you can see from your screenshot where sync.pl has an "empty" icon against it, it looks like you have not associated .pl suffix files with perl. That is why perl something.pl runs it as a perl script but plain something.pl does not. Depending on your build process, you either need to associate .pl extension so it automatically runs it with perl, or you need perl ... explicitly on the command line.



  • @JonB so why when i execute it doesn't show the message like in this sceen bellow
    0_1562668033292_7728ed0a-6e08-4309-af04-9882ee36a57f-image.png



  • @Zunneh
    I don't understand your question.

    When you execute perl C:\...syncqt.pl (second case) it runs perl on the script file and produces the lines of output you see.

    When you just execute C:\...syncqt.pl without the leading perl command (first case) it looks like it has no association for .pl files (especially in view of your screenshot showing no icon for .pl files) with perl, so it does not run perl. I don't know what it does with your file in that case, but I see no output.

    Why don't you check your Windows/Explorer file associations for .pl files? Make sure they are associated with perl, and the correct version at that?



  • @JonB i already associate the .pl files with Perl app

    0_1562669486072_test.png

    still have the same problem, can't execute the script (no output)

    @JonB and the correct version at that?
    which version are you talking about , Qt or Perl ? Thanks



  • @Zunneh
    FGS. The screenshot you show does not show you have perl associated with .pl files, it only starts at .pptmhtml which is alphabetically later than .pl anyway so it proves nothing. I can't hold your hand down to this level....



  • @JonB

    0_1562671208454_perle.png

    .pl = .profile



  • @Zunneh

    .pl = .profile

    What?? No, .pl != .profile!! They are spelt differently. What more can I say? Do you understand file extensions?


  • Lifetime Qt Champion

    @Zunneh said in Error while Executing Perl script to generate headers:

    can't execute the script (no output)

    If you, for some reason, can't associate .pl file extension with Perl then why not simply do:

    perl PATH_TO_SCRIPT
    

    ?!
    You're already doing so in your screenshot...



  • @jsulm yeah that's what i do , but no output when executing this script



  • @Zunneh
    But you showed earlier that perl ... syncqt.pl does produce output, it's in your screenshots!

    Why in the world do you not right-click on the .pl file, associate it with perl, and try again? It only takes about 10 seconds....



  • @JonB I finally found it, i was thinking that i have to run the sync.profile in the qftp master while it was the syncqt.pl in the bin file , the resemblance of the name made me deceived ,
    what an error on my part



  • now I just have to add the INCLUDE PATH to my project and add the QT + = ftp,
    if anyone can help me add the INCLUDEPATH of the modules / qt_ftp.pri ?? Thanks

    P.S : i'm following this guy : https://stackoverflow.com/questions/47744360/installing-the-qtftp-module-in-qt-5-6-0


  • Lifetime Qt Champion

    @Zunneh said in Error while Executing Perl script to generate headers:

    if anyone can help me add the INCLUDEPATH of the modules / qt_ftp.pri ??

    in pro file

    INCLUDEPATH  += PATH_TO_DIR_CONTANING_QTFTP_HEADER_FILES
    

Log in to reply