Unable to run Android App "The application caused a serious error and cannot continue"



  • I use Qt 5.12.3 and sdk and ndk as the image attached 0_1557395182487_sdk-preview.jpg .
    Unfortunately when i deploy on device i get the error "The application caused a serious error and cannot continue" and in application Output I have:
    W System.err: java.lang.Exception:
    W System.err: at org.qtproject.qt5.android.bindings.QtLoader.loadApplication(QtLoader.java:243)
    W System.err: at org.qtproject.qt5.android.bindings.QtLoader.startApp(QtLoader.java:697)
    W System.err: at org.qtproject.qt5.android.bindings.QtActivityLoader.onCreate(QtActivityLoader.java:183)
    W System.err: at org.qtproject.qt5.android.bindings.QtActivity.onCreateHook(QtActivity.java:266)
    W System.err: at org.qtproject.qt5.android.bindings.QtActivity.onCreate(QtActivity.java:273)
    W System.err: at android.app.Activity.performCreate(Activity.java:6942)
    W System.err: at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1126)
    W System.err: at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2880)
    W System.err: at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2988)
    W System.err: at android.app.ActivityThread.-wrap14(ActivityThread.java)
    W System.err: at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1631)
    W System.err: at android.os.Handler.dispatchMessage(Handler.java:102)
    W System.err: at android.os.Looper.loop(Looper.java:154)
    W System.err: at android.app.ActivityThread.main(ActivityThread.java:6682)
    W System.err: at java.lang.reflect.Method.invoke(Native Method)
    W System.err: at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1520)
    W System.err: at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1410).

    I don't know what is happening because with the same setting on Qt 12.5.1 all works normally.
    I compile with min API-24 target API-28.

    Anyone has a solution?



  • Is there more info on the Exception from logcat? Could it be a missing binary/shared lib?



  • It's very strange behaviour..because this happens only if I make an android template for the project. Instead if I don't create the template and let qt create it inside build directory all works good and no exceptions happens.
    I tried also with example project and the same thing happens.



  • This post is deleted!


  • Solved, removing and reinstalling sdk and ndk.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.