How and what version can be installed on Linux Mint 17.3 or 19.1?



  • Hi all, I am new here,
    Yesterday spent all day time from dask to dawn struggling on how to get new release working.

    On my system where installed an old 5.0.2 version was fine.
    I wish learn Qt and Qtdesigner to develop desktop, embedded (raspberry, uC Gui extended) and why not Andrioid based app.

    I made some experience on how to use IDe then I decided to upgrade to newest version. Action so wrong as showed one day struggling around without success.

    I read tons of post and removed old version, I never got applying reasoned suggestion QtCreator working out of box.
    I read a lot of bad comment this way I can understand due to frustration common user can collect from this.

    Try'd Synaptic/Software manager recommended. I read a lot of bad/good alternating comment about doesn't work, and I have to agree that but I wish discover why.

    Last 5.12.3 never opened , try'd 5.11.3 instead asI read is recommended from this forum still doesn't work.

    Doesn't start and report this error:
    :~$ /opt/Qt/Tools/QtCreator/bin/qtcreator
    QApplication: invalid style override passed, ignoring it.
    Available styles: Windows, Fusion
    /opt/Qt/Tools/QtCreator/bin/qtcreator: symbol lookup error: /opt/Qt/Tools/QtCreator/lib/Qt/plugins/platforms/../../lib/libQt5XcbQpa.so.5: undefined symbol: FT_Get_Font_Format

    after displaying error suddenly exit without core dump.
    Try'd installation from both online and offline installer, no difference.

    Revision from Synaptic/Software manager start but report no valid kit found, NO example show on welcome, so cannot compile code.
    Qt Creator 3.0.1 Based on Qt 5.2.1 (GCC 4.8.2, 64 bit)
    Built on Apr 9 2014 at 09:12:59

    no Eample shown, when import or create new project:
    0_1557213778523_Screenshot from 2019-05-07 09:22:16.png

    try'd add sdk:

    Adding Ubuntu SDK opend for a couple of second then crash down.

    I read now here ubuntu 14 is not supported and has a bug so try'd installation on fresh image Linux Mint 19.1 (based on Ubuntu 18). Try'd, fresh native Ubuntu 18 same behaviour.
    Seen same issue plague winzz too, I am out of business and disarmed about.

    So the final question, which version can be stable and how the new user can get a good experience starting up this tool?

    Question is to who use and know in deep this good IDE, I used for a day and Impressed me, I read from book but no way to.


  • Moderators

    It's been a while since I last used Mint so I may be wrong. But a general recommendation I have is:

    • definitely use new Mint version, one based on Ubuntu 16 or newer
    • use installer from Qt webpage (https://www.qt.io/download-qt-installer)
    • do not install as root, install to your home directory instead (for example /home/username/qt)
    • if it does not work out of the box (it should) run this in terminal sudo apt build-dep qt5-qmake - that will pull all necessary dependencies (and some more)


  • Hi, thank for quick and kind answer,
    If you read out across text, you can see also on Ubuntu 18.4 and Mint 19.1 fail over same way.
    try'd install package as I wrote.
    No success.

    Apply'd your suggestion:
    ****** Mint 17.3
    root@robertomint17-SVS1511C5E:/opt/Qt# apt build-dep qt5-qmake
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Picking 'qtbase-opensource-src' as source package instead of 'qt5-qmake'
    E: Unable to find a source package for qtbase-opensource-src

    *** Mint 19.1
    Reading package lists... Done
    E: You must put some 'source' URIs in your sources.list

    *** Ubuntu 18_02_4
    Qt Creator 4.5.2 Based on Qt 5.9.5 (GCC 7.3.0, 64 bit)
    Copyright 2008-2018 The Qt Company Ltd. All rights reserved.

    Reading package lists... Done
    E: You must put some 'source' URIs in your sources.list

    which URI to select have right files? At almost 3 where shown across testing versions.

    0_1557216775258_Screenshot from 2019-05-07 10:11:12.png


  • Qt Champions 2018

    @RRomano001 I use latest Qt and QtCreator on my Ubuntu 18.04 without any issues.
    Just use Qt Online Installer as @sierdzio suggested (not packages provided by Ubuntu).
    So, did you try the online installer?



  • @sierdzio Update:
    Linux Mint 17.3.
    Removed all version of Qt5

    downloaded offline installer
    qt-linux-opensource-5.0.2-x86_64-offline.run
    Some issue at startup but imported project, reconfigured compile project, welcome screen is different from how it was, from other, Example still empty but it compile code.
    Thhis platform from now to when solved remain as is.
    Example are not so important now, I learned how to manage and I can import from directory where they are.
    Valgrind is red as not install'd, I can survive without.
    0_1557218677154_Screenshot from 2019-05-07 10:43:41.png



  • @jsulm YES, I wrote what was tested, for now I don't wish broke again what is now working also if not at best as it was.
    No way to get new version running, I can experiment on fresh images of Mint 19.1 or Ubuntu 18.2.4.
    Mint 17.3 has now QtCreator 0_1557219263589_Screenshot from 2019-05-07 10:43:41.png running. I need a test application to debug hardware, GUI is simple to use, to write than cli, but how hard can be use GUI IDE?
    Oh my ....
    A development platform is now again running, I use this also if outdated, IT WORK!.
    Damn, why spend another day struggling around? Need get in touch and learn in deep how to use, then I can try adventure in configuration or installing issue. For now return develop code and learn about usage.
    Thank for assistance, I feel it can be time to prepare a guide than leave sparse suggestion create more confusion than solution.
    Try port now my cli graphic app to Qt, I learn't about network, it is now time to graphics draw I tested on first day.


  • Qt Champions 2018

    @RRomano001 You can install Valgrind from Ubuntu repository



  • @jsulm may be, never touch what is working...
    QtCreator and QT5 Installed from offline installer, is a good idea to install Valgrind again?
    Answer: definitive yes, it was gone away, no other IDE has in it... done from CLI not GUI.. no question I am more cli than gui from ancestral old old day of terminals... It is now time to choose a good book ( on paper ;) to learn more about.
    It can be time to start prepare a good guide on how to troubleshoot issues. (WIP)

    OpenOcd STM32 now work.
    GDB is Ok Valgrind is ok.
    FPGA run again...
    QTC Outdated version without example it is ok for now.
    Thank



  • @jsulm update, old version was 5_2_0 not 5_0_2 as misread by me.
    Upgraded to version 5_2_1 everything run smoothly and layout was the last one. Also app run fine controlling external hardware.

    About white example:
    installing as user installation file use Home directory space (unwanted), installing as root use /opt/Qt_xxx where xxx is rev (desired).

    Installed as root example where whitened, simple inspection revealed right where ok to all files and folder but not example folder. Fixing access right (in my case set to read oly to preserve examples intact produced a good working ide again.
    resulted IDE, Version, and running my first network App.

    One milestone is there bout how to solve install on old version.

    0_1557227993226_Screenshot from 2019-05-07 13:04:57.png


  • Qt Champions 2018

    @RRomano001 said in How and what version can be installed on Linux Mint 17.3 or 19.1?:

    One milestone is there bout how to solve install on old version.

    You should use Qt online installer instead of offline installer, then you can install any Qt version.

    Also, the "About Qt Creator" dialog does not tell you which Qt version you use! It only tells you which Qt version was used to build QtCreator (QtCreator is a Qt application).



  • @jsulm Right, thank for hint, on package was embedded same Qt version.
    Update of works:
    Ubuntu 18.02_4
    installed as root, revision 5_12_2 work out of the box, right setting. (Ubuntu is not behaving good on my pc)
    Linux Mint 19.1:
    again as root same revision from offline installer.
    Worked out of the box, just some file access right to setup on user home.
    Require some tuning to android engine, JDK and other.

    About online installer, yes this is right but downloading from network for every platform to test is a long task. Using offline is much more faster, if new image has to be reload to HDD is ready. On final release I agree your suggestion.
    Thank a lot.
    Roberto


  • Qt Champions 2018

    @RRomano001 Why do you install as root?
    You should install in your home directory with you user rights.
    Or do you want to share the Qt installation across different user accounts?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.