Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

* unsupported in the posix collation implementation



  • I'm seeing some warning/errors print out in my console with my application in Linux, and I'm not sure exactly why. The errors I see are

    1. Case insensitive sorting unsupported in the posix collation implementation
    2. Numeric mode unsupported in the posix collation implementation

    Doesn't seem to affect the program from what I can tell, but my console gets flooded with these messages from time to time.

    I have built qt manually and it's version 5.11.2 on CentOS 7 with the following configure args:
    -shared -mp -opensource -nomake examples -opengl desktop -skip wayland

    Is there possibly some configuration flag I missed, or does this point to something incorrect in the code base? Unfortunately I can't provide code, as I'm not even sure where it's being triggered yet, but will narrow that down if necessary.


  • Lifetime Qt Champion

    Hi
    They come from here
    https://code.woboq.org/qt5/qtbase/src/corelib/tools/qcollator_posix.cpp.html#49

    However, im not sure what they mean excactly.
    Seems to trigger if not C locale and locale is default from default QLocale


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    In addition to @mrjj's points, what locale are you using on that machine ?



  • Thanks for the responses. locale reports en_US.UTF-8 for everything except LC_ALL (empty).
    *edit: and if I do a 'qDebug() << QLocale().name();' it reports 'en_US'



  • Also it seems I get these messages when I have a QFileDialog open and I'm browsing different folders


  • Lifetime Qt Champion

    Do you get the same issue if you use the Qt version provide by CentOS ?



  • Hello,
    I use too QT 5.11.2 but on RedHat 6.5.
    I get the same issue described above.
    The instantiation of a QFileDialog makes appear in the terminal the following message:
    "Case insensitive sorting unsupported in the posix collation implementation
    Numeric mode unsupported in the posix collation implementation"
    I tried to set different values to LC_ALL (c, en, ...) but without success.
    Somebody has a clue?
    Thank you.



  • Hi :-)

    I'm seeing this message as well. I'm using a bare Ubuntu 16.04.6 LTS VM to build an AppImage for one of my projects. I'm building a static Qt for this, as minimalistic as possible, so that the AppImage is as small as possible.

    I recently updated to Qt 5.14.2. Just to also mention this: I had to install libxkbcommon-dev in addition to what's listed in https://doc.qt.io/qt-5/linux-requirements.html, otherwise configure would not succeed but complain about some requirement for xcb wasn't there. Maybe this package should be added to the list?

    My configure statement was:

    ../configure -prefix ~/Qt/5.14.2_static -opensource -confirm-license -release -static -optimize-size -no-harfbuzz -no-opengl -no-gif -no-ico -no-libjpeg -skip qt3d -skip qtactiveqt -skip qtandroidextras -skip qtcanvas3d -skip qtcharts -skip qtconnectivity -skip qtdatavis3d -skip qtdeclarative -skip qtdoc -skip qtgamepad -skip qtgraphicaleffects -skip qtimageformats -skip qtlocation -skip qtmacextras -skip qtmultimedia -skip qtnetworkauth -skip qtpurchasing -skip qtquickcontrols -skip qtquickcontrols2 -skip qtremoteobjects -skip qtscript -skip qtscxml -skip qtsensors -skip qtserialbus -skip qtserialport -skip qtspeech -skip qtvirtualkeyboard -skip qtwayland -skip qtwebchannel -skip qtwebengine -skip qtwebglplugin -skip qtwebsockets -skip qtwebview -skip qtwinextras -skip qtxmlpatterns -nomake examples -nomake tests -nomake tools -qt-zlib -sql-sqlite -qt-sqlite -qt-libpng -qt-pcre -qt-xcb

    Using this minimalistic Qt, only having the really needed dependencies installed, I get the following warnings on the console:

    Only C and default locale supported with the posix collation implementation
    Case insensitive sorting unsupported in the posix collation implementation
    Numeric mode unsupported in the posix collation implementation
    

    When building Qt after having done sudo apt-get build-dep qt5-default, The AppImage's size grows from 7,6 MB to 26 MB, but the messages are gone.

    So I think this is due to something that Qt includes/builds if the respective library is there and doesn't if not.

    sudo apt-get build-dep qt5-default installs the following packages here:

    autotools-dev comerr-dev debhelper dh-strip-nondeterminism freetds-common freetds-dev gdb gir1.2-atspi-2.0 gir1.2-gst-plugins-base-1.0 gir1.2-gstreamer-1.0 gir1.2-gtk-2.0 icu-devtools krb5-multidev libasound2-dev libatk1.0-dev libatspi2.0-dev libbabeltrace-ctf1 libbabeltrace1 libcairo-script-interpreter2 libcairo2-dev libct4 libcups2-dev libdbus-1-dev libdrm-dev libegl1-mesa-dev libfile-stripnondeterminism-perl libgbm-dev libgdk-pixbuf2.0-dev libgl1-mesa-dev libgles2-mesa libgles2-mesa-dev libglib2.0-dev libglu1-mesa-dev libgssrpc4 libgstreamer-plugins-base1.0-dev libgstreamer1.0-dev libgtk2.0-dev libharfbuzz-dev libharfbuzz-gobject0 libice-dev libicu-dev libinput-dev libjpeg-dev libjpeg-turbo8-dev libjpeg8-dev libkadm5clnt-mit9 libkadm5srv-mit9 libkdb5-8 libltdl-dev libmirclient-dev libmircommon-dev libmircookie-dev libmircookie2 libmircore-dev libmtdev-dev libmysqlclient-dev libmysqlclient20 libodbc1 libpango1.0-dev libpcre3-dev libpcre32-3 libpcrecpp0v5 libpixman-1-dev libpq-dev libpq5 libprotobuf-dev libprotobuf9v5 libproxy-dev libpulse-dev libsm-dev libsqlite3-dev libssl-dev libsybdb5 libudev-dev libwayland-bin libwayland-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-present-dev libxcomposite-dev libxcursor-dev libxdamage-dev libxft-dev libxinerama-dev libxml2-dev libxml2-utils libxrandr-dev libxshmfence-dev libxtst-dev libxxf86vm-dev mesa-common-dev mysql-common odbcinst odbcinst1debian2 pkg-kde-tools po-debconf publicsuffix unixodbc unixodbc-dev x11proto-composite-dev x11proto-damage-dev x11proto-dri2-dev x11proto-gl-dev x11proto-randr-dev x11proto-record-dev x11proto-xf86vidmode-dev x11proto-xinerama-dev xvfb

    Can you imagine which one could be the missing one? I'll try to figure it out, but I think I'll have to remove one, rebuild Qt, build my program and check if it was the very package … and that will take like forever ;-)



  • Okay, I found it. Installing libicu-dev (before building Qt) makes the messages disappear. My AppImage is 19 MB instead of 7,6 MB though …


Log in to reply