Building 5.12.3 on Ubuntu 19.04 results in missing x11extras module



  • I downloaded qt-everywhere-src-5.12.3.tar.xz, extracted and configured with

    OPENSSL_LIBS='-L/usr/lib/x86_64-linux-gnu -lssl -lcrypto' $SRC_FOLDER/configure -release -opensource -confirm-license -prefix $PREFIX_FOLDER -openssl-linked -static -optimize-size -ltcg -nomake examples -nomake tests -nomake tools -skip qtwebengine -skip qtdeclarative
    

    It seems to finish just fine but when trying to build a project I get

    Project ERROR: Unknown module(s) in QT: x11extras
    

    The only relevant part that happens during make is

    cd qtx11extras/ && ( test -e Makefile || /home/skyweb/Qt/5.12.3/64_static-build/qtbase/bin/qmake -o Makefile /home/skyweb/Qt/5.12.3/qt-everywhere-src-5.12.3/qtx11extras/qtx11extras.pro ) && make -f Makefile install
    make[1]: Entering directory '/home/skyweb/Qt/5.12.3/64_static-build/qtx11extras'
    cd src/ && ( test -e Makefile || /home/skyweb/Qt/5.12.3/64_static-build/qtbase/bin/qmake -o Makefile /home/skyweb/Qt/5.12.3/qt-everywhere-src-5.12.3/qtx11extras/src/src.pro ) && make -f Makefile install
    make[2]: Entering directory '/home/skyweb/Qt/5.12.3/64_static-build/qtx11extras/src'
    make[2]: Nothing to be done for 'install'.
    make[2]: Leaving directory '/home/skyweb/Qt/5.12.3/64_static-build/qtx11extras/src'
    make[1]: Leaving directory '/home/skyweb/Qt/5.12.3/64_static-build/qtx11extras'
    

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you check the configure logs to see if there's something related to that ?

    Do you have the required dependencies for that module ?



  • The configure logs don't show anything related to x11extras (https://pastebin.com/H136tpQu). I changed the configure with skipping more which is more in line with what I actually need (and builds on windows).

    I'm not sure what dependencies specifically there are but I'm not getting any messages indicating it's missing any.




  • Lifetime Qt Champion

    What do you get if you build the x11extras module manually ? (meaning creating a new folder, using your custom Qt qmake to setup the build and then calling make)



  • skyweb@vm:~/qt/5.12.3/x11$ /home/skyweb/qt/5.12.3/64_static/bin/qmake /home/skyweb/qt/5.12.3/qt-everywhere-src-5.12.3/qtx11extras/
    Info: creating stash file /home/skyweb/qt/5.12.3/x11/.qmake.stash
    Info: creating cache file /home/skyweb/qt/5.12.3/x11/.qmake.cache
    skyweb@vm:~/qt/5.12.3/x11$ make
    cd src/ && ( test -e Makefile || /home/skyweb/qt/5.12.3/64_static/bin/qmake -o Makefile /home/skyweb/qt/5.12.3/qt-everywhere-src-5.12.3/qtx11extras/src/src.pro ) && make -f Makefile 
    make[1]: Entering directory '/home/skyweb/qt/5.12.3/x11/src'
    make[1]: Nothing to be done for 'first'.
    make[1]: Leaving directory '/home/skyweb/qt/5.12.3/x11/src'
    

    And of course nothing appears.
    makefile in case it's useful.



  • Well, I tried it again with the below

    OPENSSL_LIBS='-L/usr/lib/x86_64-linux-gnu -lssl -lcrypto' $SRC_FOLDER/configure -release -opensource -confirm-license -prefix $PREFIX_FOLDER -openssl-linked -static -optimize-size -ltcg -nomake examples -nomake tests -nomake tools -skip qt3d -skip qtactiveqt -skip qtcanvas3d -skip qtconnectivity -skip qtdeclarative -skip qtdatavis3d -skip qtdoc -skip qtgamepad -skip qtcharts -skip qtgraphicaleffects -skip qtlocation -skip qtnetworkauth -skip qtpurchasing -skip qtquickcontrols -skip qtquickcontrols2 -skip qtremoteobjects -skip qtscxml -skip qtsensors -skip qtserialbus -skip qtserialport -skip qtspeech -skip qtvirtualkeyboard -skip qtwebchannel -skip qtwebengine -skip qtwebview -skip qtscript
    make
    make install
    

    And it actually doesn't complain that x11extras isn't found

    Getting other issues when building my project, related to wayland-xdg-shell and qharfbuzz: compile log These aren't errors. Guess my issue is solved without changing anything related to configure/make.



  • I am trying to build 5.12.3 on CentOS7. Qt5X11Extras module will NOT build along with the other modules. I tried the above suggestions but it still does not work.
    Question: Do I need "root" access for this to work? I am building in my own directory.


  • Lifetime Qt Champion

    Hi,

    No you don't need root access.

    Did you check the configure tests logs to see if you are missing some libraries ?


Log in to reply