Maximize not working correctly



  • A Qt5 app I wrote for myself is acting strange now that I've run it on a couple of older notebooks. Everything is fine in the VMware machine on my Debian box where it was written. It also runs fine on my i3 notebook ( Intel GPU ) in Debian and W10. When I run it on a clean Debian install on an older ( Core2, Intel GPU ) notebook. The mainwindow thinks it's maximized, but it is not full width and the height is greater than the screen height. I cannot reduce the height regardless of the corner I try to drag, even the bottom ones after I move the window around. And if I can move it, why does it show that it's already maximized?

    I've tried all the window size settings and vertical policy changes in QtCreator. I've checked to make sure all fonts and themes are the same in Gnome. I've even tried another notebook ( Pentium, Intel GPU) with the same effect.

    The only clue I have is that on my main box and my i3 notebook, buttons and headers are plain. On the two older notebooks, buttons and column headers have shaded gradients. This led me to believe it's theme related, but I can't find any differences between the systems as far as those settings go.

    I'm an old programmer, who can best be described as a hobbyist now and this looks to be beyond my knowledge set.

    Any ideas?


  • Qt Champions 2018

    @Dave4270 What Debian version is that and what window manager do you use there?



  • OK, I gave bad info. The window manager question made me realize that in my frustration, I just ran it under LXDE on my notebook, not Gnome. It does fail in Gnome on my i3 notebook. The window behaves correctly with LXDE in all instances. I can just use that, but I do still want to find out what was causing the issues in the Gnome shell.

    Thanks for the clarity. This was the product of a full head after a long week.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.