Cannot build apk or even deploy



  • Hi guys,
    I'm on windows , when i try to build my android app i have this error :

    Installing to device failed!
    15:02:22: The process "C:/Qt/5.12.2/android_x86/bin/androiddeployqt.exe" exited with code 16.
    adb: failed to stat C:/Users/fabie/Documents/build-iVactis-Android_for_x86_Clang_Qt_5_12_2_for_Android_x86-Profile/android-build//build/outputs/apk/android-build-debug.apk: No such file or directory
    

    I tried many workaround like disabling APK build ( if i do i have the error above and if i don't i got Execution failed for task ':compileDebugAidl'. )
    or changing android version 24 - 25 - 26 -27 - 28

    i also have this written in red

    > java.io.IOException: com.android.ide.common.process.ProcessException: Error while executing process C:\Users\fabie\AppData\Local\Android\Sdk\build-tools\29.0.0-rc1\aidl.exe with arguments {-pC:\Users\fabie\AppData\Local\Android\Sdk\platforms\android-27\framework.aidl -oC:\Users\fabie\Documents\build-iVactis-Android_for_x86_Clang_Qt_5_12_2_for_Android_x86-Profile\android-build\build\generated\source\aidl\debug -IC:\Users\fabie\Documents\build-iVactis-Android_for_x86_Clang_Qt_5_12_2_for_Android_x86-Profile\android-build\src -IC:\Qt\5.12.2\android_x86\src\android\java\src -IC:\Users\fabie\Documents\build-iVactis-Android_for_x86_Clang_Qt_5_12_2_for_Android_x86-Profile\android-build\aidl -IC:\Users\fabie\Documents\build-iVactis-Android_for_x86_Clang_Qt_5_12_2_for_Android_x86-Profile\android-build\src\debug\aidl -dC:\Users\fabie\AppData\Local\Temp\aidl2123399118576890321.d C:\Qt\5.12.2\android_x86\src\android\java\src\org\kde\necessitas\ministro\IMinistro.aidl}
    

    Thank you .


  • Lifetime Qt Champion

    Hi,

    Which version of the NDK are you using ?



  • SDK Version : 26.1.1 , NDK Version : 19.2.5345600
    and JDK 1.8.0_201 ( i tried more recent one but i doesn't work anymore after)



  • I still don't know how to fix that ...
    It's pretty annoying



  • Had the same issue. Looks like Android Build Tools 29 has some issues. Try to remove Android SDK Build-Tools 29-rc-1 (Options->Devices->Android->SDK Manager), install another Android SDK Build-Tools (I used 28) and remove .pro.user file of your project. Then reconfigure project and build again. For me, it helped.



  • Yes it actually works but only for x86 clang
    My phone can use only the two others arm64 and armeabi
    The problem is that when i deploy using these architecture qt force the install of SDK Build-Tools 29-rc-1 and use it.

    How do i say to qt to not use this version of SDK Build tools ?

    thank you



  • Do someone know ? please


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.