Qt Creator strange behaviour. How to fix it?



  • Hello all!
    I am using Qt Creator on MacOS. I have this strange behaviour when I am including files into project (see screenshot). Auto complete is duplicating directories. How to fix it?

    0_1551859859456_Screen Shot 2019-03-06 at 11.06.17.png

    0_1551859937431_Screen Shot 2019-03-06 at 11.11.51.png


  • Lifetime Qt Champion

    Hi,

    Can you give a step by step procedure to trigger this ?



  • Is ../XXXXXX/sources the current parh ?



  • @SGaist There are nothing special in procedure. I am only adding the header file. Sometimes there are similar troubles but for the build menu (left bottom conner of Qt Creator window). The solution that is fixing it (troubles but for the build menu) - kill *.pro.user file and reconfigure whole project. But shortly after it's appearing again. After today I will try to catch how it happening.

    Today installed update for Qt Creator. The duplicating in "#include" still appeared.


  • Lifetime Qt Champion

    Did you check with the next beta ?



  • @SGaist Not, I've not been checking beta. Just fully installed 5.12.2 - the same result.



  • @Gerhard What does it mean?


  • Moderators

    @bogong Might be a long shot, but it wouldn't surprise me that much if it's the issue.

    Can you try disabling the clang code model and check if the issue goes away ?

    QtCreator-> help -> About Plugins->ClangCodeModel



  • @J.Hilk I will do it today and reply.

    Beside all of it new portion of strange behaviour ...

    The highlighting ...
    0_1553246915292_Screen Shot 2019-03-22 at 12.25.11.png

    After updating onto 5.12.2 I've got this issue:

    • The highlighting sometimes without any reasons became broken and showing like on image;
    • The broken variables in other codes became unavailable and showing like undeclared or mistaken

    Only restart of Qt Creator fixing it. But in about hour it's happening again ...

    Sometimes this kind of behaviour switching me into "WTF" mode! :-) At this time I am happy about working alone because of a lot of uncensored terms :-)



  • @J.Hilk Just switched off QtCreator-> help -> About Plugins->ClangCodeModel The first issue became solved. All is OK with duplicating. The first impression of the switching off this plugin - QT Creator became working MUCH FASTER! It's working without unreasonable pauses.

    0_1553247706082_Screen Shot 2019-03-22 at 12.40.50.png

    But next portion of strange things above :-)



  • @J.Hilk Look on screenshot. I've got catching the problem!

    0_1553843904420_Screen Shot 2019-03-29 at 10.17.44.png

    The problem with duplicating kits appeared again. Only deleting *.user.pro and reconfiguring whole project solve it. I am not doing anything special.



  • @J.Hilk Just reconfigured again. Now problem hasn't been disappearing. In "Build&Run" still broken kits.

    0_1553845015036_Screen Shot 2019-03-29 at 10.35.25.png

    0_1553845123528_Screen Shot 2019-03-29 at 10.38.12.png

    The button "Delete" in Kits inactive. I couldn't remove broken kits.

    1_1553845267606_Screen Shot 2019-03-29 at 10.40.41.png

    0_1553845267606_Screen Shot 2019-03-29 at 10.40.25.png



  • @J.Hilk After killing Qt Creator configs (~/.config/QtProject) and total reconfiguring - again OK.

    This is the contain of the directory where located kits just after reconfiguring:

    0_1553846306007_Screen Shot 2019-03-29 at 10.55.52.png

    !!! AND THIS IS when it happening:

    0_1553846334111_Screen Shot 2019-03-29 at 10.50.21.png

    When I am working I do not change anything in settings. Just closing Qt Creator at evening time and when start it at morning having this kind of troubles (mean restart Qt Creator).


  • Moderators

    @bogong
    I'm afraid, I don't have much experience with QtCreator and it's inner workings. I'm using it, and that's about it.

    Maybe someone else has more insight on this. Or you take to the QtCreator mailing list. there are the developers active and they might be able to help you more.
    https://lists.qt-project.org/listinfo/qt-creator

    From personal experience, I can say, try completely uninstalling QtCreator and reinstall it. in 90% of all my issues that I had with it, were fixed that way.
    Time consuming, I know :(


Log in to reply