Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

How do you change the app bundle identifier that Qt puts in the Xcode file?



  • Hi all. I can't run my app on my phone from Qt Creator because Xcode whines:

    Code Signing Error: No profiles for 'com.myname.gallery-mobile'

    Which is what Qt put in the Xcode project file. If I open the project in Xcode and put a totally random bundle identifier for the target, like com.wallaby.funkymonkey, it builds fine. So... where do we change this?

    And then there's another thing. In the Xcode output, it says,

    To enable automatic signing, pass -allowProvisioningUpdates to xcodebuild.

    I found that you do this by adding the flag to the list under Project / Build Environment. But unfortunately that just changes the error message, but not its basic complaint:

    xcodebuild[62700:9920056] DVTPortal: Service '<DVTPortalAddAppIDService: 0x7fd469274f10; action='addAppId'>' encountered an unexpected result code from the portal ('9401')
    2019-03-04 01:06:38.084 xcodebuild[62700:9920056] DVTPortal: Error:
    Error Domain=DVTPortalServiceErrorDomain Code=9401 "An App ID with Identifier 'com.MyID.gallery-mobile' is not available. Please enter a different string."

    Thanks.


  • Moderators



  • @sierdzio Great, thanks! It'll be nice if that works. I can't try it at the moment, though, because my app won't build thanks to the "missing Android SDK" bug and I don't know how to temporarily turn off Android builds.


  • Moderators

    It does work, I've tried it myself recently.

    my app won't build thanks to the "missing Android SDK" bug and I don't know how to temporarily turn off Android builds.

    So you're building for macOS or iOS but Qt Creator complains about Android? Sounds like a bug, make sure you're using the newest Qt Creator.



  • @sierdzio Thanks. I am using the latest Qt Creator and all other tools.

    My project is configured for everything except iOS Simulator. That's why it's also building for Android, even though I'm not using it right now.


  • Lifetime Qt Champion

    Hi,

    In that case disable the build for Android. Or if you want to also build for Android, then install the needed dependencies.



  • @SGaist Thanks. How do you disable the build for a particular platform?

    Also: I have all the dependencies installed. The failure to detect the Android SDK is another known bug. Apparently it's related to Sun removing a Java component after years of warning that it was deprecated; I guess this was disregarded by the Android devs and now their SDK manager crashes on launch with an assertion about the now-missing Java component.


  • Lifetime Qt Champion

    Just realised something, how are you trigger that build failure ?

    Qt Creator only build for one kit at a time and build type at a time.

    As for Android, you might be using a "too new" version of Java then. The likely best approach is to revert to an older version.



  • @SGaist Thanks. The IDE must have just defaulted to the Android build for some reason then.


Log in to reply