Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Specify macos target build under qtCreator



  • hello !

    I am fairly new to Qt and Dev in general. I am more a hacker than a real developper and i use Qt and sometimes openFrameworks to build small tools for everyday use.

    Now i have pretty simple application (video player) i have developed on my computer but it will be used on another machine : my computer is a macbook pro under macOS Mojave (10.14) using QtCreator 4.8.1. The target machine will be an old macbook under Snow Leopard (10.6)

    I am looking for a way to build my app for a minimal 10.6 mac os version but don't really know how to achieve that (if even possible)

    I have added the following line in my build settings :

    QMAKE_CXXFLAGS += -mmacosx-version-min=10.6
    

    here it keeps throwing me a warning saying :

    overriding '-mmacosx-version-min=10.6' option with '--target=x86_64-apple-macosx10.9-macho' [-Woverriding-t-option]
    

    Is that to say i can only build for 10.9 as minimum ?
    If not, how can i achieve that ?

    thanks a lot



  • hi,

    thanks for the heads up
    so i ended up retrieving the old macbook and installed Qt build the app on it.

    thanks


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    You will have to go "back in time". Xcode 10 doesn't provide older SDK especially for at version as old as 10.6.

    The most simple would be to create a virtual machine with e.g. macOS 10.9 which should give you the possibilty to build your application targeting 10.6.

    You will also have to use an older version of Qt. IIRC 5.6 should be fine.

    Note that this has not much to do with Qt itself but Apple which usually support the current and two preceding version of their OS.



  • hi,

    thanks for the heads up.
    so Qt is tied to xcode under osx ?

    stange enough, when using Xcode with that same project, i can select 10.6 as target but then it complains about stdc++ needing 10.7 as minimum. I tried to add stdsc++ instead which seemed to be the standard before 10.7 and now is complaining about not finding standard libraries...



  • hi,

    thanks for the heads up
    so i ended up retrieving the old macbook and installed Qt build the app on it.

    thanks


Log in to reply