Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Unsupported Qt version, 5.9+ is required



  • I installed the latest available Qt Creator. But the project that I need to build (qgroundcontrol.pro) is giving me the following error:

    Project MESSAGE: Qt version 4.8.7
    Project ERROR: Unsupported Qt version, 5.9+ is required
    Cannot read /home/canberkgurel/qgroundcontrol/user_config.pri: No such file or directory
    

    How can I update the Qt version to be greater than 5.9?



  • @csg1

    Hi and welcome to devnet forum

    How did you install Qt creator?



  • I downloaded and ran the Qt Online Installer (http://www.qt.io/download-open-source) then set the downloaded file to executable using:

    chmod +x

    Then I double clicked on it and installed it to the default location.



  • @csg1

    So you have downloaded the online installer, which is good.

    You need to check the different version and choose one which is suitable for you. There is a menu coming up giving you the choices for Qt libs to install. The current release is Qt 5.12.1. Best is to choose this for installation. Evenually you need to update also your compiler.

    The settings in Qt creator are typically updated. Possibly you have to do a restart.

    Note: Qt creator is only an IDE. This IDE is based on and uses Qt libs. However, for using Qt libs you need to install those separately.
    In creator you can select different tool chains consiting of Qt libs and the associated compilers.



  • In the installer Select Components dialog, I chose: 5.11.3 (on Ubuntu) and it is being installed now. This should solve it. I somehow didn't see this pane in the first time I was installing it. The approximated installation size is 7.9 GB. Isn't this too large for an IDE?


  • Lifetime Qt Champion

    Hi,

    That's not the size of Qt Creator. If you just ticked the checkbox, you have likely selected the installation for desktop and android and all the related components.

    By the way, why not use the latest version available ?



  • Oh I see. That makes sense. Because 5.11.3 is what is being suggested by the project that I will be building.


  • Lifetime Qt Champion

    Qt is forward and backward compatible within a major version.



  • Unfortunately the problem still persists. The About Qt Creator displays the following:

    Qt Creator 4.8.1
    Based on Qt 5.12.0 (GCC 5.3.1 20160406 (Red Hat 5.3.1-6), 64 bit)
    Built on Jan 16 2019 00:19:04
    From revision e8df914ef2
    Copyright 2008-2018 The Qt Company Ltd. All rights reserved.
    The program is provided AS IS with NO WARRANTY OF ANY KIND, INCLUDING THE WARRANTY OF DESIGN, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
    

    but the project still outputs the same error:

    Project MESSAGE: Qt version 4.8.7
    Project ERROR: Unsupported Qt version, 5.9+ is required
    

    The code that generates this output is:

    message(Qt version $$[QT_VERSION])
    
    !equals(QT_MAJOR_VERSION, 5) | !greaterThan(QT_MINOR_VERSION, 8) {
        error("Unsupported Qt version, 5.9+ is required")
    }
    

  • Lifetime Qt Champion

    Did you change the kit used to build your project ?



  • There is only one kit installed, I assume the first one is overwritten.


  • Lifetime Qt Champion

    Is it the 5.11.3 ?
    Looks like you could be using your distribution provided Qt ?
    One other thing you can do is:

    • Close Qt Creator
    • Nuke your .pro.user file so you will have to reconfigure when opening the project
    • Start Qt Creator
    • Open your project and use the 5.11.3 Kit

  • Moderators

    @csg1 said in Unsupported Qt version, 5.9+ is required:

    There is only one kit installed, I assume the first one is overwritten.

    You did not uninstall Qt 4.8.7, so it still exists in your system. It is not overwritten.

    Follow @SGaist's latest instructions to switch to Qt 5.11.3.


Log in to reply