Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QtSDK update problem && uninstalled QtCreator



  • Hi all,
    today I started the SDKMaintenanceTool from QtCreator to install the new QtCreator.
    While downloading the updates my internet connection gone down and the download failed.

    Now I haven't QtCreator in my PC... It seems like if it was uninstalled before the end of the new downloading...

    I'm working on Slackware Linux 32 bit.



  • Start SDK maintaince tool again and choose Package Manager, then click next. In "Development Tools" section if avaible select "Qt Creator" and click next again. Hope this helps. Regards.



  • [quote author="hdarama" date="1317305176"]Start SDK maintaince tool again and choose Package Manager, then click next. In "Development Tools" section if avaible select "Qt Creator" and click next again. Hope this helps. Regards.[/quote]

    What you say isn't possible because "Qt Creator" is already checked also if there isn't the qtcreator executable in installation directory and I also can't uncheck it.

    I solved by re-installing the SDK, but I'd like to inform you about this possible BUG.



  • [quote author="Luca" date="1317305863"]
    What you say isn't possible because "Qt Creator" is already checked also if there isn't the qtcreator executable in installation directory and I also can't uncheck it....[/quote]

    :) Right. It can't be check/uncheck. I think same, it must be uncheckable.



  • I confirm the problem.
    I tried to upgrade QtSDK in my home linux PC.
    I've seen that while downloading the updates the "old" component are already uninstalled from my installation directory.
    This way, if the downloading fails or if I press "Cancel" I get an SDK without QtCreator...


  • Moderators

    Did you "file a bug report":http://bugreports.qt.nokia.com/?



  • [quote author="Tobias Hunger" date="1317491134"]Did you "file a bug report":http://bugreports.qt.nokia.com/?[/quote]

    I just reported the "bug":https://bugreports.qt.nokia.com/browse/QTSDK-954 .

    This is my first bug report so I hope have been clear... :-)


Log in to reply