QtWebEngine and Adobe Connect (Flash Player): can't switch between cameras in qt based application



  • I need to use Adobe Connect in Ubuntu 18.04. As there is no application for linux systems, i basically want to call a Adobe Connect URL with QtWebEngine (so i can add e.g. camera settings via widgets later). For this, i chose the simple browser example from Qt. I can login and enter the room, which causes the Adobe Flash Player to start as expected. In the beginning, i had to add a slot for receiving the QWebEnginePage::featurePermissionRequested signal to grant permissions, because the flash player needs access to multiple cameras.

    This seems to work fine, at least i can see the camera stream now. But whenever i want to switch to another camera (via the drop-down menu inside the flash player application), the camera-window gets black for a short period and then the same camera is shown again, independent of the choice in the drop-down menu. I also tried using the QWebEnginePage->settings() commands, which allows me to enable plugins, javascript, etc but it had no effect.

    Another thing i noticed: when the flash player app gets opened for the first time, no camera names are listed. If i start a camera i get asked and i allow the permissions. Now i close the tab and open it again. The camera names are listed now, but it still only shows the first one, no matter what camera is selected.

    I tried it on Chromium and everything is fine (because as far i know QtWebEngine is chromium-based). Chrome and Firefox work also.

    Anyone got an idea how to fix this problem?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.