QT 4.7.4 for Mac has strange Version of qdeclarativeimageprovider.h



  • I've downloaded QT 4.7.4 for Mac and tried to build KDEs Marble.
    I got errors that some class functions are not defined. Seems the compiler is right:

    The file /usr/local/Trolltech/Qt-4.7.0/include/QtDeclarative/qdeclarativeimageprovider.h

    reads like this:

    @
    class Q_DECLARATIVE_EXPORT QDeclarativeImageProvider
    {
    public:
    virtual ~QDeclarativeImageProvider();
    virtual QImage request(const QString &id) = 0;
    };
    @

    While the reference documentation here http://doc.qt.nokia.com/4.7/qdeclarativeimageprovider.html also mentions the following functions:
    @
    QDeclarativeImageProvider ( ImageType type )
    virtual ~QDeclarativeImageProvider ()
    ImageType imageType () const
    virtual QImage requestImage ( const QString & id, QSize * size, const QSize & requestedSize )
    virtual QPixmap requestPixmap ( const QString & id, QSize * size, const QSize & requestedSize )
    @
    Also the same file in the git repository http://qt.gitorious.org/qt/qt/blobs/4.7/src/declarative/qml/qdeclarativeimageprovider.h reads
    @
    class Q_DECLARATIVE_EXPORT QDeclarativeImageProvider
    {
    public:

    enum ImageType {
        Image, 
        Pixmap
    

    };
    QDeclarativeImageProvider(ImageType type);
    virtual ~QDeclarativeImageProvider();
    ImageType imageType() const;
    virtual QImage requestImage(const QString &id, QSize *size, const QSize& requestedSize);
    virtual QPixmap requestPixmap(const QString &id, QSize *size, const QSize& requestedSize);

    private:
    QDeclarativeImageProviderPrivate *d;
    };
    @
    Why is my version different? How do I get the right version of the file?

    Best regards,
    Chaos



  • Sometime you just need to read what you have written:

    /usr/local/Trolltech/Qt-4.7.0/ is quite obviously not the path for QT 4.7.4

    So why does cmake pick up a wrong path?
    And where does 4.7.4 gets installed?
    And how to safely uninstall old QT library versions?
    Why does marble claim to be compatible with QT 4.6, if it needs features from 4.7.4?

    Oh all those questions!

    I'll need to investigate ...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.