Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[Moved] QtCreator nightmare



  • I am using QtCreator and had to include windows.h indirectly(through qexserialport classes). Now the intellisense has become so slow it has become impossible to code. :( is there a way i can switch the damn thing off?



  • This might not be most suitable place for visual studio specific issues, but I found the following by googling for "visual studio 2008 disable intellisense":

    http://social.msdn.microsoft.com/Forums/en-US/vcgeneral/thread/1ac6c3fe-8256-4337-907b-ad947d7dffb4/



  • Open "Help->About Plugins" and try disabled anything from C++ category, after it restart Qt creator



  • Actually I think OP's mention of IntelliSense stems from previous usage of visual studio. OP wants to disable code completion in creator.

    Tools/Options, go to the "Text Editor"/Completion tab and change the "Activate completion" combo to the required setting (probably manually, so still enabling code completion with ctrl-space).

    Actually I'm using QtCreator 2.3 at the moment and have several files using windows headers (including windows.h) without any code completion problems at all.



  • @kakka: I am using qt creator, not visual studio as editor.
    @Franzk: I don't have code completion problems. It does pop up, but after like eternity. I switched to 2.3, as they said they do it on thread, so I will be spared with horrible wait. It was never a problem since 2.0 with only qt headers or so I think. May be I should increase the RAM on my box. But with 1.5gigs and typically only qtcreator app running, I wonder whether it will solve anything:(



  • [quote author="pkj__" date="1317126038"]
    @Franzk: I don't have code completion problems. It does pop up, but after like eternity. [/quote]That was actually what I meant. The pop-up can take a while in older versions if you have a lot of possible completions, which is why you wouldn't suffer from it if you turn off code completion (it will still be updating the code model though).

    [quote]I switched to 2.3, as they said they do it on thread, so I will be spared with horrible wait. [/quote] That's a good idea anyway. Creator made another big step forward.

    [quote]May be I should increase the RAM on my box. But with 1.5gigs and typically only qtcreator app running, I wonder whether it will solve anything:([/quote]
    Not going to solve anything. With a lot of RAM string comparisons and pattern matching are still expensive.



  • bq. Not going to solve anything. With a lot of RAM string comparisons and pattern matching are still expensive.

    Yeah, you are right. I have adopted your suggestion with success. I really doubt this is not a creator thing and more of xp problem.
    Could you share your cpu clock rate(if it is not too personal ;) ) so that I can pin point that at least it is not my box's hardware. Mine is around 2 ghz.



  • You made me blush.

    I'm on a 3G quad core right now, but I can check how slow it is on my 900MHz single core eeepc tonight.



  • bq. I’m on a 3G quad core

    With that you can probably know the answer to life, universe and everything. Oh wait, you know that already. ;)
    Please let me know how it performs on your more humane(in terms of speed) pc. Thanks a lot :)



  • On the eeepc in a fresh project it's actually not that bad, but definitely annoying when working on some code. If I include windows.h and start typing CD, it takes two or three seconds for all completions to be found.

    That was with case insensitive code completion, which is not what I normally use. With case sensitive completion (fresh start) it's shown within half a second.



  • Thanks a lot. And it looks like a good idea to have completion as case sensitive. For the problem occurs mostly with m$ code and since most of its shouting aloud anyway(I mean most of it is in CAPS), it leads to fewer troubles.


Log in to reply