Qt creator 2.3 + Qt 4.7.4 debugger issue



  • hi,

    I am working on Windows 7 on a 64-bit machine.

    I downloaded the source code for Qt 4.7.4 libraries and built them using mingw ( that i was installed from an older SDK) using the following
    configure
    mingw32-make

    Then i downloaded the source code for Qt creator 2.3 and built it against the Qt4.7.4 libraries (that i built above) using mingw
    qmake
    mingw32-make

    I am able to build and run my code using this new Qt creator 2.3 that i have just built. But if I try to set a break point and debug my code I get the following error.

    "The preferred debugger engine for debugging binaries of type 'x86-windows-msys-pe-32bit' is not available.
    The debugger engine 'Cdb engine' will be used as a fall back.
    Details:there is no gdb binary available for binaries in the format 'x86-windows-msys-pe-32bit'.

    What am I missing?

    I was using the (older) SDK with the pre-built Qt creator 2.1 until now and I had to manually install "Debugging tools for Windows". But Qt creator automatically detected this and then debugging worked. I cannot figure what I need to do to get Qt Creator 2.3 to debug my code.

    Thanks!
    Karina



  • I have the same problem and created a bug entry for qtcreator (https://bugreports.qt.nokia.com/browse/QTCREATORBUG-6134 ), unfortunately (for us), still open.

    The problem is in the executable file itself, when the debug session starts, it detects the wrong abi.

    Interestingly, if you start the program and attach the debugger to the running process, the debugger works.



  • Hi ,

    @chal61: I get the same error I described in my original post even if i "debug" the code without any breakpoints set. (I am assuming this is the situation you described).

    But with some help, I have made some progress!

    It seems that in Option->Toolchain, I did not have a debugger specified. So i remedied this by cloning the auto-detected mingw toolchain and added the path to gdb.exe (from the older SDK I had been using upto this point). This helped, but when I tried to debug my project, gdb.exe complained that it could not find a valid path to python and suggested adding an Environment variable PYTHONPATH to the python installation directory.

    So i downloaded python2.7 (pre-built) 64-bit and installed it and added the PYTHONPATH environment variable. Well, gdb.exe did not complain about not finding python but it crashed.

    Any ideas?
    Thanks!
    Karina



  • Hi,

    Qt Creator requires a special version of gdb that has support for Python scripting.
    It is found in the Qt SDK or Qt Creator packages (gdb-i686-pc-mingw32.exe).

    In that case I recommend installing a fresh version of the Qt SDK or Qt Creator and let it overwrite Qt Creator's settings. The debugger for the MinGW toolchain should then point to this binary.

    Regards,
    Friedemann



  • I think we need to wait for the bug fix.

    You didn't understand my workaround.

    1. start the application (e.g. by command line or explorer)
    2. Go to Creator menu and select:
      Debug->Start Debugging->Attach to Running External Application
    3. select the application from the processes window list
    4. the debugger will work!

    Hope this helps...



  • I solved by installing the appropriate debugger from here: http://msdn.microsoft.com/en-us/windows/hardware/gg463012#E4



  • I have encountered some debug problems,
    if you compiled the QT source with mingw 4.4 and try to debug with pythondb(shipped with old QT SDK), maybe the debug helper used old python version( 2.5),
    "here":http://115.com/file/e7lbuza2# is the new version debug helper, pythondb(python 2.7),I extracted from QTSDK 1.3.

    The website is in Chinese, if you have any problem to download it, send me a message.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.