Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Could not resolve dependency 'CppTools(4.8.0)'



  • Hi QT guys,

    I'm a newbie to QT and intend to create an widget application on a pi zero (private project). However, I've installed QT creator, latest version on my Windows 10 laptop but I get the following error from the plugin loader messages popup when I start QT creator "Could not resolve dependency 'CppTools(4.8.0)"

    I have a whole suit of other software on my PC such as VS2017 which I use for my business. Any ideas why I'm getting this as I would have expected this to have been installed.

    Thanks

    Andy



  • Hi

    Thank you. I've nailed it. I did not install creator 4.8.0 rc1 only 4.8.0.

    4.8.0 shows this:
    0_1547499073857_9858b506-0222-4797-94b7-6528e05d5bb4-image.png

    whilst installing and runing 4.8.0-rc1 shows this:
    0_1547499121812_c992d5ad-5648-4408-914c-283a1cef8e7d-image.png

    Many thanks for your help to point me in the right direction.



  • @andyDT

    Hi and welcome to devnet forum

    That message refers to the creator plugins.

    In creator go to "Help"->"About Plugins" enable "Show All" and check under "C++" for CppTools. It should be selected and no special signs.



  • Hi, Thank you for your prompt response. I have just checked, CppTools is not listed, only ClangCodeModel, ClangFormat (experimental), ClassView and CppEditor.



  • @andyDT

    You need to check
    0_1547486811158_589fa5f0-b0ae-4ca9-8a24-cb13c5cdc7e5-image.png

    and looks on my machine like this:
    0_1547486866201_78f4daba-026f-4c09-a282-d366cf828aa6-image.png



  • Hi

    Thank you. I've nailed it. I did not install creator 4.8.0 rc1 only 4.8.0.

    4.8.0 shows this:
    0_1547499073857_9858b506-0222-4797-94b7-6528e05d5bb4-image.png

    whilst installing and runing 4.8.0-rc1 shows this:
    0_1547499121812_c992d5ad-5648-4408-914c-283a1cef8e7d-image.png

    Many thanks for your help to point me in the right direction.



  • @andyDT

    creator 4.8.0 rc1 is only the first release candidate. Creator 4.8.0 should have the same or better behaviour.

    Each of your plugins have a red cross on the left. They are not available and therefore not loadable.

    How did you install the Qt creator?
    With the general online installer or separately?



  • Hi,
    I installed from the online installer as is, i.e. default selections, didn't change anything. I installed the first time, had this issue, uninstalled, reinstalled, had the same issue again. Then I used the installer to add/remove components and selected the 4.8.0rc-1, installed and that worked however 4.8.0 still does not work.



  • @andyDT

    I am going with creator release versions only so far. You may install more than one version of creator in parallel. However, as standard with the online installer you have only one, the latest, version installed in general. You may be facing a conflict having both versions in parallel.
    Personally, I would uninstall all versions and reinstall only the official released version. See, if this helps.


Log in to reply