⚠️ Forum Maintenance: Feb 6th, 8am - 14pm (UTC+2)

Noobie tutorial and 5.11 to 5.12 upgrade

  • Was working on the 'Slider' tutorial under 5.11, could never get it to work at all, noticed upgrade to 5.12 so I nuked 5.11 and installed 5.12. Only selected the MSVC files, UWP stuff, Sources and QT scripts & debug info files. After the downloads were done the install started, and I got a pile of errors saying files could not be accessed because they were being used by another process. Whatever :)

    With that said, I checked what the UWP were about, seems its all related to Win8 and up. I'm on win7 64 pro, so I uninstalled all of those, rebooted etc. Started a new instance of 'swipe' tutorial. Noticed the instructions were a bit off, and also noticed many of the ID's used were similar to the actual command(s) (i.e. StateGroup vs stateGroup. Definitely makes one think about ID names for sure. Anyway, after fixing all of those up, I got it to run, including before and after the 'transitions' were coded.

    Curious why the 'build' process is not within the same folder as the source code (so used to Visual Studio) and I also noted that after closing QT totally, there was a running process (vctips I believe) left over as being active. Guessing it has to do with QT giving info on commands and stuff. Not sure why that process is not being terminated when QT closes. Anyway :)

    Considering the qmake errors in the install with the various MSVC files, should I nuke everything, do another clean install (select everything I did before) except not choose any of the UWP files?

    Btw, nice touch on the 5.12 installer, not having to select examples etc...

  • ops, my bad.. I forgot to ask..

    In doing the swipe tutorial, there doesn't seem to be any code that relates to moving the logo back to the starting position, but indeed it does, when clicked on that mouse area. Would be pleased to know why that happens...

    Thanks again :)

  • Lifetime Qt Champion

    hi @cmwDev,

    I cannot answer all your questions, but at least:

    Curious why the 'build' process is not within the same folder as the source code (so used to Visual Studio)

    Well, as you saw, Qt supports multiple platforms and compilers. To allow easy switching between them, shadow builds are used.

    Also note, on Windows its impossible to mix debug and release objects in one app, which makes another good reason.

    and I also noted that after closing QT totally, there was a running process (vctips I believe) left over as being active.

    Never saw that one.

    Guessing it has to do with QT giving info on commands and stuff.


    Not sure why that process is not being terminated when QT closes. Anyway :)

    Better ask who started it, I'm really curious here.

    Btw, which MSVC compiler are you using? Seems you installed Qt for multiple versions.


  • Hey, thanks for the response.. I am used to Visual Studio (doing computers for 40+ years, programming for 30+) and the 'project' folder will have the source, plus in the same folder it will add in both a debug folder and a release folder. I experimented with the tools option "Build & Run", selecting the 'current directory' instead of the specific folder (in windows it uses my documents), but all that did was move the "build" folder to users/Gary rather than users/Gary/My Documents.

    My interest in using QT is due to wanting to make a small project using WinPCap, like WireShark does, but on a much smaller basis. WinPCap works well in a console, but it won't load/compile using Visual Studio and a windows form application. I'm beginning to understand that QT does things very differently and in different settings. So the 'shadow builds' make more sense based on the kits used. (I hope I got that right).

    As for the vctip part, I did some more investigating. I opened QT, checked running processes in task manager, and it was not there. I created a new scroll application, and once that code was there I checked again, and vctips was not there. I did a 'build' on it, ran it.. and vctip was running.

    "Microsoft® VC compiler and tools experience improvement data uploader" is what the program is, and its location is C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\bin\x86_amd64.

    As for the compiler choice... um... I dunno... LOL.. When I did the fresh install of QT and selected 5.12, all of the options were selected. I removed some that were of little interest to me (web, purchasing, charts, etc) but I was not sure exactly what the MSVC options were for, to be honest. My system is win7Pro 64 bit. So for my own use, I suppose all I would need would be the 2017 64, but if I wanted to make the program available to others I would probably need to build a 32 bit version as well.

    I currently use a program called WallWatcher, which gives me real time running logs of incoming and outgoing connections, supplied by the router on port 162. Sadly, most of the newer routers no longer supply logging (in real time) capabilities and the program is obsolete for the most part. I need to upgrade the old Linksys BEFSR41 since its only rated at 100mbps.

    I wonder if all of the qmake errors were because VS was installed. Maybe thats why it seems to be loading the vctip thing.


  • Lifetime Qt Champion

    Hi @cmwDev,

    I did a short googling and that came for vctip: https://visualstudio.uservoice.com/forums/330519-visual-studio-team-services/suggestions/18985093-visual-studio-build-tools-2017-option-to-disable

    So please blame MS for that spyware...

    'project' folder will have the source, plus in the same folder it will add in both a debug folder and a release folder.

    And it's doing that exactly for the reason to not mix debug and release symbols.

    So the 'shadow builds' make more sense based on the kits used. (I hope I got that right).

    Yeah, fully!

    I don't know why patching your qmake failed, I'd just try another install after full cleanup. You probably don't need the Qt sources, and I'd just install the Qt version suiting your MSVC compiler (so install Qt MSVC2017 if you have Visual Studio 2017).

    If you want to debug from within QtCreator, you will need the "Debugging Tools for Windows" also, which is a separate MS download.

    Good luck!

  • Lifetime Qt Champion

    Got one more idea: patching qmake might fail depending on your anti-virus software.

  • I got a little curious, looked at installed VS versions (2008, 2010 & 2015) in add/remove programs. Then looked in the program folder and saw Visual Studio (with no version) plus 9.0, 10.0, 12.0 and 14.0... Renamed the 12 and 14 so files would not be found, QT wasn't happy about things.

    So I loaded up VMWare Workstation 12, added in a fresh install of win7 pro, went out and got all of the windows updates. I then did an install of QT, selecting only the MSVC 2017 32 bit, depreciated script and QT debug files. The download and install went "fine" but, I got this error..


    By the looks of things, it would seem that QT wants to have VS installed. Again, nothing else was installed other than win7pro and windows updates.

  • Lifetime Qt Champion

    I have actually never tried install QT MSVC version before having the compiler installed.
    However, it complains about QScript.

    Could you for the test of it, try again and not select Qscript and see if it goes ok then ?

    Im not aware visual studio MUST be installed first as its first when starting Creator it becomes
    critical that it can find the compiler.

    Just to be 100% clear. The mingw Qt comes with compiler and debugger.
    Selecting any QT Visual Studio version, does not include compiler or debugger.
    Its forbidden by Microsoft.

    Also from your top post. Just as a note.
    Installing BOTH visual studio 2015 and 2017 makes no sense as
    2017 is compatible with 2015. (for the first time ever)

  • ops, my bad for not trimming the image.. *mutter Anyway.. :)

    My sole objective is to get a windows form-type application, that essentially has 9 columns across representing a row of information that will come from the WinPCap API's. And the api's are not 'visual studio windows forms' friendly, hence the QT thing.

    As for "whats needed", if I removed the MSVC components and just used the mingw... I guess I could try that out. If I can get a sample tutorial program to go, then really I probably don't need anything more. I guess when I try to hook in the PCap stuff, I'm sure that will be interesting.

    For the VS side, I had 15 before 17.. lol.. and I really didn't like the direction Microsoft was going. Logins required, calling home with gawd knows what information... I used to code a lot, in multiple languages and databases. But I am getting old (shush) and this is really just a program for me. If I like how it works out, I will probably give it away, etc..

  • Lifetime Qt Champion

    Well do try Creator and mingw compiler.
    Normally it just works out of the box.
    Creator is a wonderful IDE and while not as many features as
    Visual Studio, its more than enough for most tasks.

    I think your AV interrupted your first install. Had exact same situation with Avast.

  • well, I updated the QT, removed the MSVC stuff and just added in mingw.. no issues during install. Opened it and built one of the sample apps, no issues...

    I guess its time to start exploring the controls, find some sort of grid with columns, see if I can't get some of the PCap API's working.

    Fingers crossed :)


  • Lifetime Qt Champion

    That is good to hear.
    Fingers crossed :)

    For the Grid, please look into
    with a custom model with Pcap data, it would provide
    good performance with huge data sets.

  • It hates me... lol.. Since everything was fine on the VM install, I decided to change the main system. Went out and renamed the other VS folders back to their original names (just to keep Microsnot happy), removed the full QT package to start clean. Rebooted, disabled the AV (just in case... never reported problems with the other installs but, you know... fingers crossed right?) then ran the installer again. Only selected the mingw option, plus the default tools (same as I did on the VM).. got to the end and gave this error.
    Ignored it.. said it was finished. Loaded QT, went to build the sample text editor (same as on the VM, which worked) and it failed with this showing in the Application Output screen:

    14:58:17: Starting C:\Qt\Examples\Qt-5.12.0\widgets\mainwindows\build-application-Desktop_Qt_5_12_0_MinGW_64_bit-Debug\debug\application.exe...
    qt.qpa.plugin: Could not find the Qt platform plugin "windows" in ""
    This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

    *sigh.. While I could just do all this in the VM side of things, I like to go full screen on the main system (22 inch monitor) and then use the second screen (32 inch tv monitor) for docs, help files etc... and of course I can't drag those out of the VM to the other screen.

    Not sure why something that should be so simple is causing so many problems. And thanks for the grid link, I'll certainly check that out. :)


  • Lifetime Qt Champion

    Hmm that is indeed very strange. Installing mingw should not be affected by any VS installed.

    What virtualization software are you using ?
    wmware can use multiple screen so that the guest can use them too.

  • Lifetime Qt Champion


    All Qt documentation is also online, so you could just open a Webbrowser on the second screen... just a thought as workaround.

    I have no idea why patching your qmake fails, however.

  • Yeah, strange indeed. Not being a developer of QT I cant begin to ponder on where the issue is, and there seems to be a lot of issues. As for the VM, it's workstation 12... a net search shows that dual monitors can be done. Tried a couple of the 'tricks' with limited success. It was getting late, tired.. frustrated, so I just put it all away.

    Thanks for the tips and suggestions.


  • Lifetime Qt Champion

    Hi @cmwDev,

    I know these days ;)

    But there is hope: I found QTBUG-57983: For the reporter it helped to enable Application Experience.

    Maybe you give it a further try?

  • *chuckles

    I have everything "Application Experience" disabled. The actual program, every item that is referenced in task scheduler for that is disabled... Anything that I can do to stop windows from giving Microsoft any information... I have done.

    MS, even in Win7, likes to send a lot of data to the home office. Even at boot time, when the computer starts and does its first DNS queries.. Besides confirming the DNS connections, it also gets additional information to 'say hello' to MS on an entire range of multiple IP's... and all of this is just to confirm that it has internet access. Its what takes the ! mark out of the internet icon. Or to some, it means that MS knows every time you boot your system.

    Just saying :)

  • Lifetime Qt Champion

    @cmwDev I guess you're on the wrong O/S then. I've went away from MS 20 years ago. Only at work I'm forced to use it - and its getting worse with every release.

    Just saying, if MS blocks the installer, we cannot do much. Sorry.

  • I don't think MS is 'blocking' the install. The mingw version works fine on the clean install of Win7 on the VM. It does fail, with the errors shown when I do it on the main machine.

    The install on the main machine "worked" when I had the MSVC side installed, it just did that annoying thing with running that vctip part as a service of some sort. I had expected that when I nuked the main machine install and re-did the install with just mingw it would work.

    It did not.

  • Lifetime Qt Champion

    @cmwDev Have you read the bug report I linked?

  • sorry for the delay, I wasn't expecting more replies :)

    Yes, I did, twice. It linked to another forum, and I got a little lost but the second time I viewed it I spent time doing more in depth reading.

    So I changed the Application Experience service from disabled to automatic, did a reboot just to be safe. Nuked the previous new install of the latest QT (3.0.6 I believe), ran the installer again. I checked off the mingw, and the 2 debug items. This time, I also went down to the Tools section of the installer, and checked the same mingw item there.

    Ran the install... no errors. Ran QT, did a sample app build (notebook) and ran it, no problems. Closed QT. Went back into services, stopped Application Experience, disabled the service. Ran QT again, loaded the 'contacts' sample app, ran it.. no problems.

    Crazy that ... can't say much more. Other than I don't have to worry about running and having the dual screen hassles with VMWare. So, thanks!

    Shakes head at Microsoft... *mutters


  • Lifetime Qt Champion

    @cmwDev woo-hoo! I'm glad you finally solved it.

    Regarding MS... no, I won't give a comment.

    Enjoy coding!

Log in to reply