[Solved] How to build debug libraries with Qt 4.7.4 + Qt Creator 2.3

  • Hi to all,

    I have a problem related to the setup options of the last Qt SDK 1.1.3 ful with all the components updated.
    In a Windows 7 environment correctly configured to develop symbian aplpications I have removed the previous Qt 4.7.3 version and installed the last Qt SDK release including Qt 4.7.4 and Qt Creator 2.3.0 In this environment with CODA running with the WLAN configuration on my device(s) - C7-00 and E7-00 already used for development - I can run and test the application but can't debug.

    To debug the application (expecially QML that is my need) I have tried to configure the debug version from the Project section but - as expected - the debug libraries were not built on my machine. Thus from Tools/Options menu of Qt Creator I have tried to compile the libraries. Any tries results in an error that it is impossible to build. I have tested the building with all the compiler toolchains both for the simulator and the symbian^3 devices with the same result.

    Qmldump component is regularly built for the debug and release versions
    While trying to compile the QML debugging library I get the following log:
    Building helper(s) with toolchain 'MinGW from Simulator Qt for MinGW 4.4 (Qt SDK)' ...
    Building helper 'QML Debugging' in E:/QtSDK-1.3/Simulator/Qt/mingw//qtc-qmldbg/
    Running e:/qtsdk-1.3/simulator/qt/mingw/bin/qmake.exe -spec win32-g++ qmljsdebugger.pro -nocache ...
    mingw32-make.exe not found in PATH
    Build failed.
    It is strange because mingw ir present and I have not changed any of the default path of the installation. I am aware that the symbian projects are on drive E:\ that is the same where the Qt is installed because using different drives can cause problems in path settings.

    Some suggestion ? Thank you.

  • I have found the solution after a detaled analisys of the toolchain parameters in the Options windows menu. FYI the following note explain how to solve this issue related to the bug #QTSDK-834

    Please note that there is the actually open bug "#QTSDK-834":https://bugreports.qt.nokia.com/browse/QTSDK-834 related to the clean reinstallaton: not all the previous configuration settings are removed as expected.

    The solution is to manually check in the Qt Creator options (Menu: Tools->Options) all the paths that are marked in red correcting them with the right installation root folder.

    The second solution is to reinstall Qt SDK 4.7.4 in the same folder where there was the previous removed installation.

    This issue influences at least the debug QML/JS library compilation essential for the QML source debugging.

  • Added a note to the wiki page "How to do a clean uninstall and reinstall of Qt SDK":http://developer.qt.nokia.com/wiki/How_to_do_a_clean_uninstall_and_reinstall_of_qt_sdk/.

  • Moderators

    Thanks for sharing, Enrico.

    I fixed your link by omitting the /edit at the end. Obviously you didn't submit your changes yet.

    After checking the differences in the content I saw your changes were not saved unfortunately. Could you add the changes again?

  • Hi eddy, thank you.

    I have updated again the wiki page. Usually I save always a copy of my changes/corrections so it was not difficult to add it again. It is not the first thime that an edited page disappear :)

    Please let me know if it appears outside of my borwser.

    Cheers, Enrico

  • Moderators

    Thanks Enrico.

    Looking good now.

    You say you have that behaviour often? Even after clicking the submit button in the wiki? I usually check the article history and we would expect if you see it there it should be saved on the server.



  • Hi,

    no, not always, but it is not the first time that after clicking submit i see the final page correct then after a while the page is returned to its origin. IIRC it happened two or three times.
    It is difficult that it depends by the connection (i.e. session closed) because immediately after submitting I see the page correct. Is possible that the database record transition for some reason is updated locally but not committed to the globla database set or something similar. I don't know what is the DB management of the Nokia Devel CMS / CMF so I can't investigate in depth. Then I have not mentioned this problem in the beta testers forum because I have not reproducible conditions. This is the first time that we have a cross analisys of this behavior.

  • Moderators

    I think you could make a bug report for this. You already had it 3 times and you checked the submit process.

    The fact that the /edit was in the link you copied could be the cause. When I clicked your original link I got as a result the wiki page in edit mode. That looks like the submit didn't succeed.

  • Thank you of you suggestion, Eddy. I will move this discussion in a bug on the Beta tester forum.

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.