Using Qt in VS under Windows7



  • Hello.

    I'm using Qt embedded 4.7.0 with VS2008 Pro under WinXp to build applications for a Windows Ce 6 system. This works fine.

    Now I've installed Windows 7 on another harddisk. I've installed VS and the qt-vs-addin-1.1.9. Then I tried to add my Qt embedded 4.7.0 in VS. I've done this by starting VS with administrator rights...

    But when I tried it I've got the message (Hopefully correctly translated):
    The platform "STANDARDSDK_600 # replace with actual SDK name (ARMV4I)" is not defined within Visual Studio. Make sure you have installed the required SDK.

    I've asked google but found no solution.

    Many Thanks in advance.


  • Moderators

    Did you install the windows ce SDK on the windows 7 system?



  • Thank you for your reply.

    I think so. I've installed the SDK which comes with my Windows Ce device. I think this is an Windows Ce SKD?

    And I can see that it is correctly installed by using 'checksdk -list'



  • push



  • Nobody any ideas?



  • It doesn't make sense to regularly push a topic if there are no answers.
    I suppose, one push should be enough.

    By the way, the error you get looks like a VS error, so perhaps try to ask them in some MS VS forums?



  • I don't think that this is a VS error. I get this error by using a 'non native' menu in VS. The Qt menu appeares only after installing the VS-Addin.

    That is why I think this is a Qt-VS-Addin error.

    The second reason why I think so, is that the errorstring is defined
    "here":http://qt.gitorious.org/qt-labs/vstools/commit/ab660c6a7c2c029def7af979d53a4ce7a7f00fa3?format=patch



  • STANDARDSDK_600 is just a placeholder for the REAL SDK NAME.

    For a more complete explanation look here:
    http://developer.qt.nokia.com/forums/viewreply/46075/

    And here:
    http://developer.qt.nokia.com/forums/viewthread/5341



  • @L.MCH: Thank you for your links. Unfortunately they didn't really helped... And yes, you are right. I don't know why this placeholder appears in the error message instead of the real sdk. Anyway, I'm facing the same problem on new Windows XP installation.

    But here the correct skd name (PicoMOD4 Core (ARMV4I)) is mentioned in the error message (see screenshot). But as you can see, the correct sdk is installed (red marked)

    http://img833.imageshack.us/img833/1566/qtvs01.png

    So I don't understand why I get this error message.

    Any more ideas?



  • Uhm! I can think of three possible explanations:

    Have you tried uninstalling qt-vs-addin-1.1.9 and trying again with qt-vs-addin-1.1.7 ?

    I'm currently using 1.1.7 on VS2005 because both 1.1.8 and 1.1.9 didn't allowed me to upgrade existing projects to newer versions of Qt (i.e. upgrading from Qt 4.7.2 to 4.7.3 the recognized the Qt as "version 0".

    Your problem looks a different one, but maybe on VS2008 the same qt-vs-adding bug has different side effect.

    I usually build all the Qt libraries from command line and use Visual Studio only to develop Qt applications, are you trying to build Qt from within Visual Studio IDE ?

    Did your rebuilt Qt from scratch for PicoMOD4 Core or used a precompiled build?

    Maybe there is a mismatch between SDK name and Qt build options.
    The SDK name is "PicoMOD4 Core", the " (ARMV4I)" is the selected code generation option
    and Qt should have been compiled for "PicoMOD4 Core" with:
    CE_SDK = "PicoMOD4 Core"
    CE_ARCH = ARMV4I
    or with
    CE_SDK = PicoMOD4 Core
    CE_ARCH = ARMV4I
    in the qmake.conf file inside the mkspec subfolder with the specific build options for the selected device (in Qt sources).



  • I'm experiencing the same issue. M.MCH - I'd like to try your first suggestion, but I don't know how to get version 1.1.7 of the Qt VS Addin. Can anyone point me to a place where I can download version 1.1.7?


  • Moderators

    All previous versions of vsaddin are available in the FTP "archive":ftp://ftp.qt.nokia.com/vsaddin/



  • Thanks for the link koahnig, really appreciate it!



  • I tried version 1.1.7 of the Visual Studio Add-in but I'm experiencing the same error.

    After looking over the discussion in this thread again, I'm wondering if what I entered for CE_SDK in my mkspec's qmake.conf file has anything to do with it. This is what I had my CE_SDK value set to when I cross-compiled Qt:

    CE_SDK = NewArmCustom SDK # replace with actual SDK name

    In essence, I kept the comment at the end of the line. Could having the comment in there cause this problem? I ask because if it has no bearing on the issue, I'd rather not go through the long process of re-cross-compiling Qt. :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.