This Qt version is not compatible to your current Visual Studio???



  • Hi there, I have Qt libraries version 4.7.3 deployed and fully functional on my PC, using VS2010 and the Qt add-in 1.1.9
    I have recently downloaded Qt libraries 4.7.4 and tried to deploy on my laptop, after initially installing the add-in it had Qt version 4.7.4 showing up in the add-in settings, but none of my projects using QT actually ran - the IDE did not recognize Qt libraries. When I deleted the 4.7.4. entry from the add-in and tried to add it again manually I got the following error message popup:

    This Qt version is not compatible to your current Visual Studio (Qt builds VS version: 1500, current version: 1600)

    Both my PC and my laptop run the same version of Visual Studio - 2010 SP1, but the laptop VS fails to work with either 4.7.4 as well as the 4.7.3 version that works on my desktop pc. I have rebuilt QT but it still refuses to work.

    I have to sell my PC soon and It is a real bummer Qt fails to run on my laptop, since that will practically leave me out in the cold.

    Any ideas?



  • There is only a VS2008 version available at the the download pages at http://qt.nokia.com/downloads - where did you get your package from?

    Are you sure that you do not have an additional VS2008 on your PC?

    If you need Qt libs for VS2010 you'll most likely need to compile that yourself. It's not hard to do, so it shouldn't be a blocker for your migration. Just make sure to download the plain source package and do not use the sources included in the prebuilt packages for your build step!



  • If you already re-build Qt with VS2010 (like Volker said) make sure that you use VS-Add-in latest version (redownload and reinstall the add-in if already have 1.1.9), there was a bug with VS 2010 and the add-in with the same error maybe you have an version with the bug.



  • I've used the VS2008 version with VS2010 SP1 since April, but I have compiled Qt. I also tried compiling Qt on my laptop but to no avail... perhaps I should try to compile another version, but the VS version is currently working fine under Win 7 64bit VS2010 SP1 - same as the laptop - and no, I do not have VS2008. Will try compiling the plain package tomorrow, hope it works, cuz I will be dropping the PC in about 2 weeks.



  • Zlatomir - I had the latest add-on, and I too suspected it might be a bug, because initially, the add-on accepted the Qt libraries even thou they did not work in VS, but after I removed the Qt entry and added it anew the add-in spewed out that incompatibility message I posted. It should be a bug considering the same VS+Qt combo runs on my desktop and only fails on the laptop.



  • Have you tried to redownload and reinstall the addin?
    As far as i remember the version number didn't change when the bug was solved, so you can have "latest" 1.1.9 with the bug - and the one that can be downloaded now is still 1.1.9 with the bug solved.

    LE: Other option is to try with an older version of the add-in



  • OK, so, I downloaded the vanilla sources and compiled Qt all over again, and this time the add-in is working fine, accepting the Qt folder without version build error messages.

    However, opening even the simplest projects still reveals problems. I get an error on the first line of my main.cpp file, which is #include <QApplication>, basically despite the working add-in and compiled libraries, I get errors on every <> include, missing methods and so on...

    Any ideas?



  • Did you create a Qt project? If no, the Qt headers are missing from the include path.



  • Well, I am opening VS projects I have done on my PC and are currently working just fine on my PC with Qt 4.7.2. Is there a reason a project which works fine on my PC fails on my laptop, the only difference is on the PC I have Qt 4.7.2 for VC recompiled, on the laptop 4.7.4 everywhere compiled, everything else is identical? If so, what steps do I need to take to be able to migrate my projects to my laptop?

    I have noticed when I create a new Qt project on the laptop it is all working fine, however, instead of #include <QApplication> the Qt project template uses #include <QtGui/QApplication>, I have tried modifying the includes on my existing projects in the same manner but to no avail... So current laptop config has no problem creating new projects but is not happy with already existing Qt projects which work just fine on my PC



  • You can look at the project settings whether the Qt dirs are included in the header include path. If not, something is wrong, if yes, maybe your Qt version is different or missing to the plugin, you will have to add the path to your installation then.


  • Moderators

    It could be that the "Qt Project settings" "Properties" are assigned to a specific version of Qt in your project. When you transfer the project to another PC it will carry on these settings. When the very same version is not available on the new PC you got problems. If I remember correctly are the error messages pointing somehow to the right, but with a number of subprojects it becomes a little obscure.

    You should check under in menu "Qt" the "Qt Project Settings" the version assigned. After using specific versions there, I have switched to "$(DefaultQtVersion)". It will use then the Default version assigned in "Qt Options" in menu "Qt".

    This change cured version conflicts when moving source between different machines awith different Qt versions and target platforms.



  • Well, this is strange...

    After I switched to DefaultQtVersion I was able to build an existing project and it seems to be running fine, and yet VS underscores the #include <QApplication> as an error, and when I hove over it, the tip says "error: cannot open source file "QApllication""

    Anyway, thanks a lot, I am happy that it is finally working, my previous projects are not that important, basically exercises, since I am still learning, however it was kind of annoying to not be able to transfer existing projects and have them working.



  • After nmake install I start MS VISUAL Studio 2010 but it is not possible to use that version of Qt with Qt options Add. The error is C:\Qt\5.0.0-x64-rc2-opengl-mysql\qmake.exe could not be ...
    So I am not abel to use this installation. Curious


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.