Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Project ERROR: Unknown module(s) in QT: 3dstudioruntime2



  • Hello everyone
    I have win10 machine and downloaded Qt also Qt3DStudio, but the problem is after editing scene in Qt3DStudio then I opening it on QtCreator.
    When I try to build the project, QtCreator says "unknown module(s) in QT: 3dstudioruntime2". Okey no problem I just opened up MaintenanceTool and downloaded it. But still Qt gives me same error, how to solve it ? Thanks



  • @xmastree said in Project ERROR: Unknown module(s) in QT: 3dstudioruntime2:

    But still Qt gives me same error

    Did you rerun qmake and cleaned the build directory before retrying after installing the new module?



  • Yes, I did it, click Build -> qmake then clean, or clean all, or everything about clean,
    But same error happens still, also restarted computer.



  • In qml I can not "import QtStudio3D 2.0"
    What is wrong with it, I reinstalled Qt again, Please help me guys!



  • I am having the same problem on Windows 7. I have tried installing the latest (beta) version and the 2.0 version of the 3D Studio Runtime 2, but all of the example apps that require it, fail to build with the error:

    Unknown module(s) in QT: 3dstudioruntime2

    I think perhaps the Qt maintenance tool does not install it correctly?

    Is there a work-around available for this?

    Thanks, Clay



  • I am also worried about with this problem, in the old version of qt and 3D studio. I build it success. but when I updated ,it doesn't work. should we build the module?



  • @Shae

    Can you please specify with which versions of Studio3D and Qt Creator it was working?

    Thanks, Clay



  • @Clay-Montgomery I solved this problem with 3Dstudio 2.1 and the Qt 5.11.2



  • @Shae Are you using Microsoft Visual Studio 2015 or 2017? Do you build for 32 or 64 bit?

    I think the issue is that the Qt 3D Studio Runtime does not work with the MinGW toolchain that Qt Creator defaults to. I had to install Visual Studio 2015 and configure the examples to build with that (32 bit) to get past the error about the 3D Studio Runtime module 2 not being found. This worked once with a few examples, but it is still not stable. The 3D Studio examples crash most of the time I run them.

    The components I am using now are:
    Qt 5.11.2
    Qt Creator 4.7.0
    Qt 3D Studio 2.1.0
    Qt 3D Studio Runtime 2.1.0-rc

    Regards, Clay



  • I used MSVC 2015 Qt5.12, not found the 3D studioruntime2. the components I used the same with you ,and it worked.


Log in to reply