Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[Solved] Program with QCA library crashing on other computers



  • I'm trying QCA library, specifically AES encryption, everything's working fine on computer with Qt SDK, but when I try to run program on other computers, it crashes. I don't know if i'm missing some dlls, or there's some other problem. I have qca2.dll in program directory, qca-ossl plugin in crypto subdirectory, I have dlls from openssl library.
    Does anybode have any clue?



  • You will have to provide more information.

    What does "crash" mean? Are there any error messages or stack traces?
    Did you accidentally ship a release version of your application with debug libraries or vice versa?



  • here's screenshot:
    !http://macav.panacom.sk/crash.png!

    i've tried also debug version and release versions, i didn't combine them. Are there some dll dependencies other than openssl dlls?



  • just one more thing, when I run qcatool2.exe, it says "Cannot load library qca-ossl2.dll: The specified procedure could not be found."



  • Are you sure that you aren't mixing different library versions?



  • Okay, I made it work :) Previously, I used binaries downloaded from qca site, now I tried to compile latest 2.0.3 version, then qca-ossl plugin and it's working.
    thanks



  • Hi,
    i followed all the steps given in the below link
    http://www.essentialunix.org/index.php?option=com_content&view=article&id=48:qcatutorial&catid=34:qttutorials&Itemid=53.

    firstly, I am able to compile latest qca 2.0.3 and able to call library functions in Qca.
    Second, I am able to compile and make qca-ossl2.dll..but i am unable to load the this dll.( that y i m not able to call aes, rsa, and other block cipher algos)

    this the error i m getting when i using the qcatool2.exe
    qca-ossl2.dll: failed to load: The plugin 'C:/QtSDK/Desktop/Qt/4.7.4/mingw/plugins/crypto/qca-ossl2.dll' uses incompatible Qt library. Expected build key "Windows mingw release full-config", got "Windows mingw debug full-config".

    if possible please explain installation procedure how u compiled qca-ossl dll

    OS:
    windows : version 7
    QT version: 4.7.4
    Qt creator: 2.3.1



  • well, according to the error, I guess you're combining release and debug builds. I Built QCA and qca-ossl2 as both debug and release. I used "GNU Make":http://www.gnu.org/software/make/ but i think that's irrelevant .. procedure is in README/INSTALL files.. i did something like this:
    QCA:
    configure --debug-and-release
    make
    installwin

    qca-ossl2:
    configwin rd
    qmake
    make
    copy lib*.dll qtdir\plugins\crypto



  • hi,
    I followed all the steps mentioned in the above post. but still i m unable to load qca-ossl plugin. when i m using QCA::supportedFeatures().. this is the following response (sha1", "key"random", "md5", "storelist")



  • do you have dlls from openssl in the folder where exe file is? i'm not sure, but i think the necessary are ssleay32.dll and libeay32.dll



  • still not able to load the plugin



  • I ran out of ideas, check one more time that you have all necessary files in the folder with exe, and qca-ossl2.dll in subfolder "crypto" ..
    if you're still not able to load the plguin, you can try openssl library directly, without qca



  • i also followed all the steps given in the below link
    http://www.essentialunix.org/index.php?option=com_content&view=article&id=48:qcatutorial&catid=34:qttutorials&Itemid=53.

    i can using the QCA's funtion,when i deploy the nessary dlls and exe to other computers.
    there is a error with QCA.
    I have checked it.the QCA can not loaded ,so i call the QCA's funtion and get a panic.

    so i need help ,every one ,thanks


Log in to reply