Important: Please read the Qt Code of Conduct -

Connection to Forum always lost on FireFox?

  • FireFox won't stay connected. When i view the forums, i get the spinny thing at the top of the window:

    0_1535951759301_Screen Shot 2018-09-02 at 10.09.39 PM.png
    and this message at the bottom right:

    0_1535951773145_Screen Shot 2018-09-02 at 10.09.27 PM.png

    pretty consistently. it goes away sometimes, after a while. but it happens EVERY time. Chrome seems to work, at least the ONE time i tried it (now)

  • I'm only using Firefox and don't have the problem you're describing. Try in a private windows, if working this could indicate a cookie problem or incompatibility with an add-on.

  • Lifetime Qt Champion

    @davecotter I have this too, and I remember a thread one or two weeks ago from @VRonin who had the same problem. I seems to be a forum software bug.


  • Can confirm it happens to me too a lot. Looks like this bug but the workaround suggested doesn't work for me

  • @davecotter
    I use FF under Linux and it happens to me all the time. I thought it was me! :)

  • @JohanSolo using a private window did not help, same problem

  • I get this same error with Chrome browser. I'm not sure if it's browser-dependent or something more subtle, but I just had to use a different machine that has an ancient version of Google's Canary (experimental) browser to post the last couple messages to this forum.

    I've been seeing the error under Chrome for months, but today, it was impossible to post anything. I could log in. I could read forum messages, but pressing the 'new topic' button did nothing.

    Both machines are running Windows. I'll check the Linux machines later, but I'm sure I've seen similar in the past.

    You'd think it would be relatively easy to trace that error message back to its source. Perhaps it's some kind of watchdog timeout glitch.

  • Ping @ollipuu if you know more how we could solve/get around this problem (cc @AndyS)

  • Moderators

    Assuming that it is in fact the same problem as reported on NodeBB then it seems that we are stuck in this respect if the workaround is not working. They are waiting on a fix in a package they depend on too so I don't know much more about how it can be worked around. If more users are ending up having more problems however with the latest version of Chrome/Firefox then we'll have to see if we can somehow solve it more directly.

  • I tried to reproduce the issue, but without luck. I subscribed to that NodeBB ticket just in case that bug gets fixed and then we could maybe think about updating the forum software at the same time.

  • I just tried Internet Explorer on the same machine where Chrome gave the lost connection message. I figured that it would show the same, but ... surprise, no disconnect message. Weird.

  • I now stopped having this problem. As an important note, however, the workaround suggested in the NodeBB bug report breaks completely the system

Log in to reply