[Solved] E7 and screen lid + screensaver



  • Hello,

    I have an application where I use the devices camera with QCamera. If I use the camera with E7 screen lid open and close the lid the system forces screensaver on even when I have inhibited within the app. This forces the camera to shutdown.

    Is there anyway to keep the camera running in the background or disable the screensaver when sliding the lid down?



  • This seems a problem of setup on the E7.

    You can go in E7 Application Menu and open the settings -> phone -> slide handling. Here you can set what is the behavior of the device when you open / close the device. If you disable the screensaver in the app I think this act only on the timeout screensaver start while this is related to the opening/closing of the lid. You can also setup the Slide handling to do nothing when it is opened or closed.



  • aah thanks, i check those out!



  • Yep. This is the reason taht I moved your thread in this area.

    Regarding E7 and the camera there are a couple of things that you can do on the device:

    As explained above set the lid beahavior. Despite the camera setting I found not so good that closing the lid the applicationgo in standby etc. So you can set what action you want.

    E7 has a standby sliding button to the left side. When you have the camera running if you go in standby the camera is already working: sliding the button again exits from the standby mode.

    If you launch the camera from the application menu, a shortcut or the camera button then pressing the menu button the camera goes in standby mode (different from the device standby) but the application don't close. As you press the camera button again the applicaiton reactivates and the camera is immediately ready. The same when the camera is running while the device goes in one of the other modes.

    As I know if you leave the camera inactive (simply do nothing) the camera go in standby mode anyway. I am not sure if this behavior can be changed but this is a parameter that you can see in the camera setup application.



  • Please if it is the solution edit the main topic adding [Solved]

    Thks


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.