Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt module not installed in QtDesigner



  • Hi guys,

    Please help me ......
    I tried to import QtChart, QtWebKit, QtSensors, etc (except quickcontrol2) from qtdesigner but in qt designer i got a warning about QtChart/QtBluetooth/QtSensor is not installed,. i dont know why that is happen. I tried install qt from online installer or offline but still got that problem, and i check all module in that installer.
    how to solved thats problem? or maybe because i only install community version??

    Thanks.
    Best Regards

    M.Rizal Jauhari



  • @mr.jo
    Can you show a screen capture of the options you set in the installer?



  • @Diracsbracket
    i installed qt in /opt/Qt using root.
    0_1535173997248_Screenshot at 2018-08-25 12-12-34.png
    in that image shown warning in navigator because i import module qtCharts.



  • @mr.jo
    These are only warnings; everything works fine?

    It seems to happen with the latest version of Qt Creator, also on my Win10 platform with Qt 11.0 : After having used it for a while, possibly after switching projects a couple of times, my imports get flagged as "not installed", although the project compiles correctly. Usually, these warnings go away after I restart Qt Creator...



  • but i tried to add chartview in myqml but my app is crashed. but if i tried using example , thats working fine.



  • @mr.jo
    If the examples work, then something must be wrong with your code or project setup.
    Look at the .pro file of the examples and check if you have the right values for the QT variable etc, e.g.

    QT += qml quick widgets



  • @Diracsbracket i write like example and never forget to add module in .pro, i dont know why in qtdesigner still get warning like that,.
    is qtchart have form like qtquick control2 in qt designer?



  • ok the problem because qtchart cannot combine with qguiapplication, i use qapplication and application is work ! but next question is why my chart is not shown in qt designer form editor??



  • like this @Diracsbracket
    0_1535186220407_Screenshot at 2018-08-25 15-36-31.png



  • @mr.jo
    What do you mean? In the image, the chart is currently selected, and its parameters are shown in the Right panel.

    If you mean that it does not appear in the list of QML types to choose from, I don't know why that is. It does not appear in mine either.

    I have tried the to build the designer plugin as described here:
    https://stackoverflow.com/questions/37869807/qt-charts-and-data-visualization-widgets
    But it does not help to add those types to the QML type list.



  • yes its selected,. but if i want to change coordinate or size the charts form, i must change from source code?we cant just change from designer like a qt quick control or basic form? or maybe i dont understand how qt designer's work? or maybe thats module for designer only available for commercial version?
    0_1535203752538_WhatsApp Image 2018-08-25 at 20.27.55.jpeg



  • @mr.jo
    You can change e.g. the size and position from both the code and Qt Designer.
    In fact, in Qt Designer, you can have both the code and the form view side-by-side.
    If you change the code, you will see the corresponding Qt Designer fields updated
    accordingly.
    This has nothing to do with a license. QtCharts no longer requires a commercial
    license.

    0_1535204908352_264d3c1a-9e79-43e8-aec2-a20cc924f5ae-image.png



  • @Diracsbracket thanks alot , but we still cant see widget qtchart in designer? just a blank form like that, right??



  • @mr.jo
    Yes. You don't see the actual contents of the graph in Designer. You must run the program to see it.



  • @Diracsbracket said in Qt module not installed in QtDesigner:

    gner. You must run the program to see it.

    but i confuse about that warning, maybe ok i cant see in designer, i just code that what paramater i need for that charts and not use a designer but its bother me hahaha. is it bug on qt designer and module, or maybe thats qtdesigner's work. fyi bluetooth sensor websocket webengine and many module have a warning like that. its bother me !!! haha..



  • @mr.jo
    Yes, I agree. These false warnings are annoying and should get fixed.



  • @Diracsbracket but if u check in QT instalation folder in /qt/version/gcc_64/ there is all module that u installed, maybe qtcreator not using that path so qtcreator got that warning. if u check in /qt/Tools/QtCreator/lib/Qt/qml ,that folder not contain all module maybe just base module.



  • @mr.jo
    I have all modules, yet get the warnings, even in Qt Creator after a while in the QML source code. That must be a bug.



  • @Diracsbracket i tried to compile plugin qtchart again from source and get libqtchartdesigner.so then i put in path gcc_64/plugins/designer, after that i run designer from gcc_64/bin/ (standalone), and i got qt chart chartview widget, but still not have qtchart widget in qt quick designer(qt creator). :D im still tried how this application works perfectly haha. maybe because configuration path in qml emulation layer, but i dont know what it is :D



  • @mr.jo
    To be honest, I've never used Designer for QML. Due to the declarative nature of QML, I find it easier to just work from the code directly.



  • @Diracsbracket me too bro, but im curious with that warning, im using designer just want to know how my app looks like, without waiting for compilation. :D because the more complex the application is the longer the compilation.



  • @mr.jo
    Sure.



  • @Diracsbracket thank bro for your infomation. :D



  • int main(int argc, char *argv[])
    {
        // Qt Charts uses Qt Graphics View Framework for drawing, therefore QApplication must be used.
        QApplication app(argc, argv);
    
        QQuickView viewer;
    
        // The following are needed to make examples run without having to install the module
        // in desktop environments.
    #ifdef Q_OS_WIN
        QString extraImportPath(QStringLiteral("%1/../../../../%2"));
    #else
        QString extraImportPath(QStringLiteral("%1/../../../%2"));
    #endif
        viewer.engine()->addImportPath(extraImportPath.arg(QGuiApplication::applicationDirPath(),
                                          QString::fromLatin1("qml")));
        //***** [Solve] FORCE THE MODULE TO BE IMPORTED.
        QObject::connect(viewer.engine(), &QQmlEngine::quit, &viewer, &QWindow::close);
        
        qDebug() << viewer.engine()->importPathList();
    
        viewer.setTitle(QStringLiteral("QML Axes"));
        viewer.setSource(QUrl("qrc:/qml/qmlaxes/main.qml"));
        viewer.setResizeMode(QQuickView::SizeRootObjectToView);
        viewer.show();
    
        return app.exec();
    }
    

    [Output through qDebug()]
    ("/home/snjee/workspace_qt/maxelecPrjs/build-maxCoffeeTdsMeterApp-Desktop_Qt_5_15_2_GCC_64bit-Debug", "qrc:/qt-project.org/imports", "/opt/Qt/5.15.2/gcc_64/qml")

    You can find the answer in the built-in "QML Axes" example source.



  • "... is not installed"
    "found not working imports...."
    I have now found the correct solution.
    All problems were solved.
    => Solutions : https://stackoverflow.com/questions/22320541/import-qtquick-controls-2-1-qml-module-not-found


Log in to reply