QtCreator 3.6 not recognising changes



  • I am using QtCreator 3.6 with Qt 5.6 on Windows 10 and are making some changes to my code before starting the debugger via the debug button. However, at one point I noticed that whatever changes I made to my code, they weren't being applied to my program. e.g I wrote

    qDebug() << "TEST";
    

    in main.cpp and when I tried debugging, it didn't even appear. I deleted the contents on main.cpp and saved it and when I started debugging, it succeeded still using the same old code before.

    I tried cleaning my project through "Clean All" and "Clean Project" before rebuilding again but that didn't make it work either.
    I also tried exiting closing the project, exiting QtCreator, restarting my PC and cleaning/rebuilding everything again from scratch but it still uses the old code and any changes I make aren't used. When I tried writing syntax errors into my cpp files, it recognised the errors and stopped compilation but when I removed it, it still uses the old code before.

    Why is this happening?



  • Solved. I don't know why but I deleted the files in the output debug folder and did a clean rebuild which seemed to solve the problem.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.