Problems with Windows deployment



  • Hi. I'm a MacOs programmer trying to port my application to windows.

    My application runs without problem when started from QtCreator.

    When I try to start it from the command line I got an exception without any kind of explanation.

    My .pro file only uses: QT += core gui

    This application already runs in a MacOs version where I just need to deploy QtGui and QtCore shared libraries.

    In the application directory I am copying the following files:

    • libgcc_s_dw2.dll

    • mingwm10.dll

    • QtCore4.dll

    • QtGui4.dll

    Am I missing some file?

    Thank's in Advance,

    Ary Medeiros



  • Are you compiling your application as release?

    What kind of exception are you getting? Is there a stack trace or something?



  • The same problems occours in both versions, release and debug. In this case is the release version.

    The exception that I got is a message that my app found an error and must be closed. And ask's me to send an error report to Microsoft. When I click for details, it shows me the an exception accours into the module qtcore4.dll ModVer 4.6.3.0 Offset: 0x005402b.

    The strange thing is that when I run my app through QtCreator it runs with no error.


  • Moderators

    Sounds like you are missing some files...

    There is a nice tool called procmon for windows which is a great help in a situation like this: It can list (among other things) all the files a application tried to open.



  • Thanks you both for the quick answer. I used the tool mentioned ahead, and found that the working directory used by QtCreator was diferent than my executable. Due this I got 2 missing files.

    Now I keep moving again.

    Thanks!!!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.