Flash disabled from 8/3 Qt 5.11.1



  • Flash was properly installed, enabled and working in Qt 5.11.1 using QtWebengine until today 2018-08-03
    Apparently something built-in triggered in Flash or Chrome on 8/3 - pages detect that there is flash plugin installed but (thinking it is) not enabled for the website...

    Testing with 'Qt Simple Browser' exmaple shows 'Couldn't load plugin' on http://get.adobe.com/flashplayer/about/
    and clicking [Check now] on https://helpx.adobe.com/flash-player.html
    now shows
    Flash Player is pre-installed in Google Chrome, but not enabled.
    You can skp the steps below. See Enable Flash Player on Google Chrome.

    YOUR SYSTEM INFORMATION
    Your Flash Version Flash Player disabled
    Your browser name Google Chrome
    Your Operating System (OS) Windows (Windows 8)

    Clicking on suggested link - Enable Flash Player on Google Chrome
    http://helpx.adobe.com/flash-player/kb/enabling-flash-player-chrome.html
    reveals that now this has to be enabled per individual web site(s)
    The site needs Flash to work
    If you visit a website and it isn’t working, you may need to change your site settings to allow Flash.

    To the left of the web address, click Lock Lock or Info Information.
    At the bottom, click Site Settings.
    In the new tab, to the right of "Flash," click Allow.
    Go back to the site and reload the page.

    I guess that corresponds to that browser pop-up (click to play) in other browser
    How to show that dialog or enable that option (per site) or any other workaround so we can have flash back in QtWebEngine?

    I'm already setting flash properly (and app was working fine until today)

    websetting->setAttribute(QWebEngineSettings::PluginsEnabled, true);
    

    but today when I open flash game for ex. there's an arrow pointing up - where click to play dialog should be in a normal browser - just QWebEngine is showing nothing...

    Sample message from a popular flash game
    'You're almost there! There's only one more thing you need in order to play: Click the button below and when the browser pop-up opens, click "Allow".'
    Tested with both 'Qt Simple Browser' and Nano browser from Qt examples - both fail
    https://helpx.adobe.com/flash-player.html
    http://www.adobe.com/products/flash/about/

    An example of what is required to enable flash in Chrome today
    https://support.digication.com/hc/en-us/articles/115003963468-Enabling-Flash-for-Google-Chrome-Windows-Macintosh-

    Now the question is how to do that in QtWebEngine - I don't need the whole GUI/dialog just plain code - a global setting in QWebEngineSettings, or similar approach to QWebEngineCookieStore but for individual (per site) settings
    ...otherwise flash plugin is totally unuasble in QtWebEngine today :-(



  • Found temp. and ugly workaround
    open https://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager02.html
    navigate to 3rd tab Global Security Settings and change either [Always Allow] or [Edit Locations] and add some websites

    The problem with that approach is - it works for global flash installation only but not for mine custom qt.conf (prevents flash settings dialog - black window /proper size/ flickers on a different position then closes instead of moving to center)
    qt.conf
    [Paths]
    Prefix=.
    LibraryExecutables=.
    Data=.
    Translations=translations

    or it could be loading flash from same folder as executable, don't know where it expects to find its settings stored, just deleting qt.conf solves that problem currently but I don't know which flash is used actually - probably global one (bad option)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.