Raspberry Pi EGL VNC?



  • Hi there,

    Sorry, Iam not shure if Raspberry belong into embedded or Desktop...

    I used a Raspberry Pi2 for quite some time as a wheater station and I wrote a simple gui in Qt for that.

    0_1531374490178_20180712_073905.jpg
    That worked quite well and I also could connect to the station, that was running x11vnc and control the gui via vnc.

    But since I had a complete reinstall (upgrade from 5.7 to 5.10) of qt
    and I recompiled the wheater app I cannot see the interface anymore via vnc, I see only the desktop.

    All I see via vnc is this:
    0_1531374579678_Bildschirmfoto_2018-07-12_07-49-24.png
    its the terminal on which I started my wheater app.

    So something has changed since the Qt upgrade... Maybe it has something to do with what GL interace now uses? Can it be it uses now this EGL instead of OpenGL? I am very confused by the difference of OpenGL, EGL(fs)?, GLes??.

    Can I revert the behaviour somehow to the old state that I had before the update? Can anyone explain what's going on?



  • Problem solved by starting my Qt App via

    -platform xcb
    

    suffix.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.