How to integrate QT 5.9 with Visual Studio 2017



  • I want to use some of the additional library and QT as an UI.

    So I decided to use Visual Studio 2017 for the same.

    After lots of search i went to the following link and installed all the required package:
    http://cse.ucdenver.edu/~mchoi/4565/installing_vs2017qt591.htm

    But after successful installation and integration once i created the project. I got error saying,
    "Exception from HRESULT: 0x80042003"
    and in Visual Studio output windows says:
    "Project 'QtGuiApplication1' could not be loaded because you need to be running Windows 10. Please update Windows to continue development on your Universal Windows project."

    I am using Windows 7 and QT 5.9, are they incompatible.

    Does Universal Windows Platform (UWP) needs window 10?

    Also bellow thread says:
    https://developercommunity.visualstudio.com/content/problem/242391/exception-from-hresult-0x80042003-creating-c-visua.html

    Which means we can not use window 7 for QT and Visual Studio integration.

    Is there any workaround for window 7 and visual studion 2017 for this?



  • In the image from that link:
    qt installation

    looks like you selected the UWP instead of the msvc2017 64-bit version



  • Thanks a lot...

    I have tried the steps and project is fabulously build...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.