Create .apk for using androiddeployqt.exe: mingw32-make: *** No rule to make target 'install'. Stop.



  • Hello,
    I am trying to release really simple app into .apk format using Deploying an Application on Android tutorial. In step one im getting make error "mingw32-make: *** No rule to make target 'install'. Stop.".

    I have done:

    • Installed Qt (I did not know what is really needed so I ticked everything under Qt 5.11.0 and Tools), Android NDK r10e and Android SDK (again ticked full android-28 and Android 7.1). Set up paths in settings.

    • Written simple app (just combo box which writes selected index using qDebug()), I changed nothing in .pro file

    • Created empty directory D:\Android-Build where I want to release app so I changed Projects->Android for armeabi-v7a (GCC 4.9, Qt 5.11.0 for Android armv7)->Build->Edit build configuration: Release->General->Build Directory to "D:\Android-Build" (Shadow Build is ticked)

    • Hit run qmake (by right click on project folder) and build

    • Opened cmd (basic windows one, not anything from Qt what pops up when I searched for "cmd") and navigated to my project folder D:\Users\User\Documents\QtProjects\Android\App01

    • Run "D:\Qt\5.11.0\android_armv7\bin\androiddeployqt.exe --output D:\Android-Build --input D:\Android-Build\android-libApp01.so-deployment-settings.json" and it said: "Application binary is not in output directory: D:/Android-Build//libs/armeabi-v7a/libApp01.so. Please run 'mingw32-make install INSTALL_ROOT=D:/Android-Build/' first."

    • So I run "D:\Qt\Tools\mingw530_32\bin\mingw32-make install INSTALL_ROOT=D:\Android-Build" and error "mingw32-make: *** No rule to make target 'install'. Stop." occured

    Thanks for any ideas as I am completelly stuck here

    Edit:
    Here is my .pro file:

    QT += quick
    CONFIG += c++11
    
    # The following define makes your compiler emit warnings if you use
    # any feature of Qt which as been marked deprecated (the exact warnings
    # depend on your compiler). Please consult the documentation of the
    # deprecated API in order to know how to port your code away from it.
    DEFINES += QT_DEPRECATED_WARNINGS
    
    # You can also make your code fail to compile if you use deprecated APIs.
    # In order to do so, uncomment the following line.
    # You can also select to disable deprecated APIs only up to a certain version of Qt.
    #DEFINES += QT_DISABLE_DEPRECATED_BEFORE=0x060000    # disables all the APIs deprecated before Qt 6.0.0
    
    SOURCES += \
            main.cpp \
        backend.cpp
    
    RESOURCES += qml.qrc
    
    # Additional import path used to resolve QML modules in Qt Creator's code model
    QML_IMPORT_PATH =
    
    # Additional import path used to resolve QML modules just for Qt Quick Designer
    QML_DESIGNER_IMPORT_PATH =
    
    # Default rules for deployment.
    qnx: target.path = /tmp/$${TARGET}/bin
    else: unix:!android: target.path = /opt/$${TARGET}/bin
    !isEmpty(target.path): INSTALLS += target
    
    HEADERS += \
        backend.h
    
    


  • I solved it, I was runing make from mingw, not from android.

    I should first navigate into D:\Android-Build directory and then run C:\android-ndk-r10e\prebuilt\windows-x86_64\bin\make.exe install INSTALL_ROOT=D:\Android-Build


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.