Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

connection mysql5.7.22 with qt5.10.1



  • Hello

    I'm relatively new to QT and C++.

    I'm working on ubuntu 16.04 64 Bit.
    QT 5.10.1

    am using mysql5.7.22

    But I always get the same error:
    "QSqlDatabase: QMYSQL driver not loaded
    QSqlDatabase: available drivers: QSQLITE QMYSQL QMYSQL3 QODBC QODBC3 QPSQL QPSQL7"

    this my .pro.......................

    #-------------------------------------------------
    #
    # Project created by QtCreator 2018-06-09T16:24:43
    #
    #-------------------------------------------------
    
    QT       += core gui
    QT        +=sql
    
    greaterThan(QT_MAJOR_VERSION, 4): QT += widgets
    CONFIG += qtc_runnable
    
    # The following define makes your compiler emit warnings if you use
    # any feature of Qt which has been marked as deprecated (the exact warnings
    # depend on your compiler). Please consult the documentation of the
    # deprecated API in order to know how to port your code away from it.
    DEFINES += QT_DEPRECATED_WARNINGS
    
    # You can also make your code fail to compile if you use deprecated APIs.
    # In order to do so, uncomment the following line.
    # You can also select to disable deprecated APIs only up to a certain version of Qt.
    #DEFINES += QT_DISABLE_DEPRECATED_BEFORE=0x060000    # disables all the APIs deprecated before Qt 6.0.0
    
    
    
    
    SOURCES += \
            main.cpp \
            mainwindow.cpp
    
    HEADERS += \
            mainwindow.h
    
    FORMS += \
            mainwindow.ui
    



Log in to reply