Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qtlocation run with linuxfb not draw MapPolyline



  • Hi,
    I write simply code That draw line in map.
    If I run the program in windows manager line is displayed corectly.
    When I run the program without xserver ( with parametr -plugins linuxfb) map is displayed corectly, but no line is showen.

    I need run program without xserver.
    Can you help me?

    Thank for help

    import QtQuick 2.9
    import QtQuick.Window 2.2
    import QtLocation 5.6
    import QtPositioning 5.6
    
    Window {
        width: 640
        height: 480
        visible: true
    
    
        Plugin {
            id: mapPlugin
            name: "osm"
        }
    
        Map {
            anchors.fill: parent
            plugin: mapPlugin
            center: QtPositioning.coordinate(59.9, 10.75)
            zoomLevel: 14
    
            MapPolyline {
               path:[
                {latitude:59.85, longitude:10.70},
                {latitude:59.97, longitude:10.86}
               ]
    
               line.color: 'red'
               line.width: 5
            }
    
        }
    }
    
    


  • Same behavior on Qt5.10 and Qt5.11 - maybe it's bug?


Log in to reply