Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

How to install Qt 3D of Qt 5.6.1 in Linux ?



  • sudo apt-get install qt3d5-dev
    qt3d5-dev : 依赖: libqt53dcore5 (= 5.5.1-5) 但是它将不会被安装
    依赖: libqt53dinput5 (= 5.5.1-5) 但是它将不会被安装
    依赖: libqt53dquick5 (= 5.5.1-5) 但是它将不会被安装
    依赖: libqt53dquickrenderer5 (= 5.5.1-5) 但是它将不会被安装
    依赖: libqt53drenderer5 (= 5.5.1-5) 但是它将不会被安装
    E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

    sudo apt-get install libqt53dcore5
    libqt53dcore5 : 依赖: qtbase-abi-5-5-1 但无法安装它
    E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。



  • "in Linux" is a bit generic... also there is no reason to use an outdated patch version, use 5.6.3 at least

    for Ubuntu Xenial:

    sudo apt-add-repository -y ppa:beineri/opt-qt563-xenial 
    sudo apt-get update
    sudo apt-get install qt56base qt56tools qt56declarative qt56quickcontrols2 qt563d 
    

    See https://launchpad.net/~beineri


Log in to reply