Qt World Summit: Submit your Presentation

[Solved]Compiles fine under release/debug, only runs under debug.

  • My code compiles fine on both release and debug, but if I compile it as release it runs- but doesnt work.
    eg; It qDebugs what its supposed to (connected, info, etcetc) but no GUI comes up. No errors, it just doesnt seem to be working properly, I dont see the account on the flash side which makes me believe its hanging somewhere after the connection (CPU usage goes right up, but it never seems to crash or anything).

    If I run it from the debug compile, it runs fine, qDebugs fine, GUI comes up right away, and I can see the account on the flash side.

    Any ideas on why this would be happening?

    Ive tried under 32bit Windows 7 and Debian

  • There are many possible causes. One might be a problem with finding the right libraries for your release version to run.

  • How do I check theyre the right version?
    Anything else I use compiles and runs fine under release, its just this project that doesnt.

    Fixed, found a loop causing the problem.
    Still not sure why it didnt hang under debug, though.

Log in to reply