"onecore" error messages & segfaults only when debugging



  • Hi,

    I am experiencing problems while debugging my QML-based app. All the following error messages do not appear when I just run (Ctrl+r), they only do so in debug mode (F5).

    [Symptom A]

    When the Program window comes to front, I get:

    onecore\com\combase\inc\comcataloghelpers.hpp(67)\combase.dll!746B8550: (caller: 746B82E0) ReturnHr(1) tid(43f4) 80004002 Schnittstelle nicht unterst├╝tzt
    ("No such interface supported") and
    mincore\com\oleaut32\dispatch\ups.cpp(2125)\OLEAUT32.dll!73CA234F: (caller: 73CA1EF1) ReturnHr(1) tid(2b70) 8002801D Bibliothek nicht registriert.
    ("Library not registered", same again for ReturnHr(2)).

    [Symptom B]

    Also, interestingly, I can not see svg images when debugging. Fine when just running.

    [Symptom C]

    Opening a FileDialog from QtQuick.Dialogs 1.2 in debug mode, I get the loads of errors (again: works in run mode) - and afterwards it eventually crashes (with segfault) at seemingly random times (but soon).

    First error message is

    onecoreuap\shell\windows.storage\regfldr.cpp(1239)\windows.storage.dll!74A1A719: (caller: 74A186F0) ReturnHr(1) tid(2b70) 80004001 Nicht implementiert

    ("Not implemented"), then several of these:

    onecoreuap\shell\windows.storage\kfapi\folderpathidlistcache.cpp(208)\windows.storage.dll!74A5B07C: (caller: 74A5A36C) LogHr(1) tid(97c) 80070002 Das System kann die angegebene Datei nicht finden.

    ("The system cannot find the file specified") After this, a specified drive can't be found (multiple times),

    onecoreuap\shell\lib\bindctx.cpp(128)\SHELL32.dll!757F0C37: (caller: 757EB0F0) ReturnHr(1) tid(97c) 80070057 Falscher Parameter.

    ("Wrong parameter") and

    shell\comdlg32\fileopensave.cpp(14268)\comdlg32.dll!752CE4A3: (caller: 752D97BC) ReturnHr(1) tid(97c) 80004005 Unbekannter Fehler

    CallContext:[\PickerModalLoop] onecoreuap\shell\windows.storage\regfldr.cpp(1239)\windows.storage.dll!74A1A719: (caller: 74A186F0) ReturnHr(29) tid(97c) 80004001 Nicht implementiert

    ("Unknown Error" and "Not implemented")

    Are these symtoms related?

    Is all this related to https://bugreports.qt.io/browse/QTBUG-63789?

    Are there any solutions, workarounds or even ideas on how to get debugging to work properly again?

    Best regards,

    Sebastian

    P.S.:

    • Qt 5.10.0 as well as 5.10.1, MinGW / 32bit Debug
    • Windows Version 10.0.16299 Build 16299, 64 bit
    • QtCreator 4.2.1,
    • Three Monitors.


  • Hi there,
    I'm debugging a Direct3D 11.x application and I'm experiencing very similar error messages:

    onecore\com\combase\inc\comcataloghelpers.hpp(67)\combase.dll!00007FFF6B86FE7A: (caller: 00007FFF6B86E2D5) ReturnHr(1) tid(6f18) 80004002 No such interface supported

    Followed shortly by:

    mincore\com\oleaut32\dispatch\ups.cpp(2125)\OLEAUT32.dll!00007FFF699C4D32: (caller: 00007FFF699C4E96) ReturnHr(1) tid(4078) 8002801D Library not registered.
    mincore\com\oleaut32\dispatch\ups.cpp(2125)\OLEAUT32.dll!00007FFF699C4D32: (caller: 00007FFF699C4E96) ReturnHr(2) tid(4078) 8002801D Library not registered.

    I tried reinstalling Visual Studio 2017, it didn't help. Hopefully Microsoft will see this and have a solution soon.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.