VS addin can not locate the newly built Qt4.7.3 from source



  • Hi,

    I’ve just built my 64bit Qt 4.7.3 binaries with MS VC++ 2008 Pro, on Windows 2003 Server (64bit). Binaries are in good condition so to speak =>). (dumpbin shows them x64 ).

    Yet installing the Qt VS Addin 1.1.9 doesn’t amount to anything, although it installs successfully.
    (edit: Added a new environment variable QTDIR pointing to the qt4.7.4. source folder (d:\qt4.7.3\src ) (with bin/lib folders under it). Added d:\qt4.7.3\bin folder to the PATH system variable. Started a VC 2008 win64 command prompt and executed the VS Addin installer from there)

    Even though the usual Qt menu item doesn’t show on the main menu on Visual Studio, I am able to go on starting to create a new Qt library project. On the last step, visual add-in bails out by “unable to a Qt build! To solve this problem specify a Qt build.”

    Yet Qt menu item is not shown on the menu, therefore no means to specify zilch.!

    On a side note; I’ve installed prebuilt Qt (32bit) for MSVC 2008 using the installer – and that’s not what I want because I need 64bit libraries-, the problem goes away. (I’ve uninstalled it)

    So how do I get the addin to pull in the 64bit libraries I’ve built to use with the VS?

    any insight is highly sought and appreciated.



  • Is your VS express edition? I heard that it does not support the plugin (oops: there is the pro, sorry)
    [quote author="cuyan" date="1313763582"]
    Started a VC 2008 win64 command prompt and executed the VS Addin installer from there)[/quote]

    Never did it that way, just double-clicked, but maybe its nothing.

    Regards



  • I add this to the Path
    %QTDIR%;%QTDIR%\bin;%QTDIR%\lib
    Correct, QTDIR points to the source folder.

    1. Please make sure you compiled Qt with a current/updated VS. It might not be the case for 2008, but 2010 gives some problem if it is not updated with the last service pack.
    2. I am not using server, but my older version of the add-in, which was installed on my old XP, somewhat the same age of server 2003, presented the Qt project config in the menu Tools\Options.
    3. Try to see if the add-in is checked on the Tools\Add-in Manager... menu options
      If it is not there, maybe it is a bug.


  • Hey problem solved?
    if (Solved)
    {
    how did you compiled the x64 version? Maybe the error is there.
    A try to re-install VS2008.
    I will be glad to try to help you.
    }
    else
    {
    Use Qt instead of QT in your posts, sometimes this causes confusion to search engines, QuickTime vs Qt.
    Edit the post -> [Solved]
    }
    Regards,
    VitorAMJ



  • [SOLVED]

    Guys, thanks for your followups.

    The main issue was to get Qt VS add-in to recognize the Qt libraries installed into the system. A Paul Jurczak at stackoverflow had already an answer to it .

    He says:
    [
    Start registry editor.
    HKEY_CURRENT_USER\Software\Trolltech\Versions\DefaultQtVersion

    and edit it to current version number. Check other entries in Trolltech group, to make sure they are set to current version. That solved the problem of

    Unable to find a Qt build! To solve this problem specify a Qt build for me.
    ]

    In my case, I set the current version of Qt as the one I built (by setting the value of QTDIR to it).

    NOTE: The Qt VS Addin menu item still not shown though, yet my solution compiles and links. (using Visual Studio 2008 Pro , not the Express addition !! )



  • Okay, got that. At least it is runing, but let's try to make your Qt menu show up.

    I also could not find in my system any registry key used only by the addin yet.
    I have done some search and maybe you can try to do some/all of these things:

    There is this system variable called QMAKESPEC, that you can set to "win32-msvc2008". Maybe it has nothing to do with the addin, but set it anyway.

    Close the Visual Studio, run Qt configure command again, and reopen the Visual Studio. I saw some guys that resolved your issue this way on the net.

    uninstall and reinstall your addin since you had changed your environment configs since then.

    Regards,
    VitorAMJ



  • Wait, forgot to mention that I ran the installation that installs prebuilt Qt 4.7.1 32bit libraries (for MS VC2008 ) first.

    That installation created the registry entries, then I edited them.

    Not to mention, I didn't have any use for the 32bit libraries.



  • Did you try to uninstall your QtSDK first, then run again the configure "your parameters for win32-msvc2008, etc...", nmake, then nmake install?
    EDIT: uninstall everything.

    Regards,
    VitorAMJ


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.