Raspberry Zero W cross compile configuration



  • Hello,
    I have problems configuring QT 5.10 on Ubuntu (laptop), the purpose is build an application for Raspberry Zero W target.
    The problem I guess is related to the QT version, I mean, the Rpi is ARM6 and I found available ARM7 but for Android and ARM5 in old versions again for Android.
    Based on this, I get errors like "the compiler cannot produce code for QT version...." so, can someone tell me which version should work with Rpi Zero W? A lot of tutorials but no one that is really 100% clear or working...
    Starting from QT version maybe the way will be more easy..
    Thanks
    Bye
    Andrea



  • @Andreagugu you may need to follow a Qt cross-compile guide, as ARM7 for Android has nothing to do with Raspberry Pi devices.
    Have you tried this tutorial from ICS? which is based on this guide as well.



  • Thanks, I already had a look to these guides without arrive at the end..
    ![Error message](0_1517600964062_783c2b6a-d5dc-4ccf-8f21-1dfaeabc3e22-image.png image url)

    Just to do things in the best way, I retried all steps suggested by the guide you reported. I took the second one as reference and I get en error in the step 10:
    ![Step10](0_1517601107963_1eeb8d29-5567-48af-813f-0b4a9a636dae-image.png image url)

    I selected rpi 1 as reference because checking the hardware, the rpi zero W has same processor ARM6 then rpi1.
    Additionally I have Ubuntu 64 bit..

    Any idea?



  • I solved!
    I recreated the Ubuntu virtual machine from scratch and I followed all steps in the guide but there are some steps not perfectly explained.. Specially the step 10, the explanation is "get qtbase..." but at least in my case installing the version 5.9.1 (I decided to follow strictly.. :-P) qtbase was not present in my pc. So I tried installing 5.10 and voilĂ ! qtbase appears and I had the possibility to go ahead.
    Another point, maybe a step where to install necessary tools.. like git, but, ok, was easy to find in the git web-site.

    Finally I really happy to solve.
    Thanks

    Bye
    Andrea


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.