QGraphicsView with OpenGL backend



  • Hi,

    I'm using a QGraphicsView to display QML items with OpenGL backend because in my case it's faster than raster.
    The application window is made translucent with :
    @
    DwmExtendFrameIntoClientArea(hwnd, &margins);

    QPalette p;
    
    p.setColor( QPalette::Base, Qt::transparent);
    setPalette(p);
    setAttribute(Qt::WA_TranslucentBackground ,true );
    

    @
    which works, but it seems the OpenGL buffer is not cleared properly on QML item state changes (different states are visible at the same time).

    To get around this I reimplemented the GraphicsView drawBackground to manually clear the background like this :
    @
    void FigureEditor::drawBackground ( QPainter * painter, const QRectF & rect )
    {
    HDC hDC = GetDC(parentWidget()->winId());
    HGLRC hRC = wglGetCurrentContext();

    wglMakeCurrent( hDC, hRC );
    
    QColor clearColor = paletteBackgroundColor();
    glClearColor(clearColor.red(),clearColor.green(),clearColor.blue(),clearColor.alpha());
    glClear(GL_COLOR_BUFFER_BIT);
    
    qDebug() << "clear background :" << rect;
    QGraphicsView::drawBackground(painter, rect);
    

    }
    @
    where FigureEditor is a QGraphicsView, but items don't repaint where it seems they should :

    This a test case :
    !http://i51.tinypic.com/2h51vs3.png!
    Clicking on the topmost square change it to blue and move it :
    !http://i54.tinypic.com/2nsm7ih.png!
    And leaves a hole when going back to first state:
    !http://i55.tinypic.com/2d6kr29.png!

    I don't get how the QML items are painted after states changes.
    Do anybody know how to solve this problem.

    Sorry for the lenghty post.

    Mickael

    [EDIT: fixed image links, Volker]



  • Did you try to clear the depth buffer also?

    @glClear(GL_COLOR_BUFFER_BIT | GL_DEPTH_BUFFER_BIT);@

    Regards,
    VitorAMJ



  • Thanks for the suggestion. I tried that but it doesn't help. Changing states still produce holes.

    One solution could be to force a full repaint every state changes but I think it could be expensive on the real application.

    Mickael



  • Did you enabled the GL_DEPTH_TEST?





  • Maybe its not related, but there is also "these":http://stackoverflow.com/questions/274410/opengl-background-transparency clues



  • Actually, I think QGraphicsView is not supposed to clear the entire screen on each paint event because it only paints portion of the screen beeing updated. By using glclear it breaks its way of painting and do not know it should repaint all objects and so leaves holes. This can be solved by setting :
    @setViewportUpdateMode(QGraphicsView::FullViewportUpdate);@

    Finally, I think the real issue is how to clear updated regions with a transparent OpenGL background.



  • Your problem, as the image shows, seems to be some sort of Z fight.
    It is in fact panting the background (last image), but missing who comes first or something on that area of wrongly blue background.

    Can you provide your code so that I can play with it?

    Thanks,
    VitorAMJ



  • Thanks for your help.

    You can download my test case here : http://www.megaupload.com/?d=51WDQWF1
    Actualy, it's a slight modification of the ported canvas example from QT SDK.
    You'll need at least windows vista to run it.



  • That's just bad. Same happening to me...

    As you noticed, the behavior of the program changes when you change from
    @ QApplication::setGraphicsSystem("opengl");@
    to
    @ QApplication::setGraphicsSystem("raster");@
    This points to a bug. You can use JIRA to report it.

    As you also point out, here the error also vanishes when setting
    @ setViewportUpdateMode(QGraphicsView::FullViewportUpdate);@
    at the cost of updating everything.

    I have tried several things, that you probably have also tried. I have set a QGLWidget to the viewport of the GraphicsScene using:
    @ QApplication::setGraphicsSystem("raster");@

    @setViewport(new QGLWidget(QGLFormat(QGL::SampleBuffers)));@
    But then there is no cool background anymore. Not supported, it seems.

    I have tried to add states to the qml to force the updates of the rectangles, but it doesn't work either.

    I am trying some more stuff to get around the bug later,

    Regards,
    VitorAMJ



  • Yes, it seems there is no clean solution to this issue.

    Thanks anyway for trying.

    Regards,
    Mickael





  • Well, I guess I'll use the glClear + fullViewportUpdate option.



  • if you have a not that complex scene (like few rectangle areas) raster might be an option. Otherwise (non-rectangular areas, rotated rectangles, and other stuff), OpenGL can be faster.

    I hope they can solve this bug fast and with a good rendering solution. But I honestly don't believe that it will be much faster ( maybe even not faster) than your workaround. That because if they change only parts of the screen, the bootleneck will still be in the driver sending stuff and possible context changes (considering that the user has a somewhat good GPU).

    Let's wait and see!

    Regards,
    VitorAMJ


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.