git clone --no-checkout git://code.qt.io/qt/qt3d.git qt3d exited with status 32768 at ./init-repository line 198.



  • Trying to clone & initialize QT repository but getting below error. Already check & applied alot of fixes and none of them worked.

    ./init-repository
    + git submodule init qt3d qtactiveqt qtandroidextras qtbase qtcanvas3d qtcharts qtconnectivity qtdatavis3d qtdeclarative qtdoc qtgamepad qtgraphicaleffects qtimageformats qtlocation qtmacextras qtmultimedia qtnetworkauth qtpurchasing qtqa qtquickcontrols qtquickcontrols2 qtremoteobjects qtrepotools qtscript qtscxml qtsensors qtserialbus qtserialport qtspeech qtsvg qttools qttranslations qtvirtualkeyboard qtwayland qtwebchannel qtwebengine qtwebglplugin qtwebsockets qtwebview qtwinextras qtx11extras qtxmlpatterns
    Submodule 'qt3d' (git://code.qt.io/qt/qt3d.git) registered for path 'qt3d'
    Submodule 'qtactiveqt' (git://code.qt.io/qt/qtactiveqt.git) registered for path 'qtactiveqt'
    Submodule 'qtandroidextras' (git://code.qt.io/qt/qtandroidextras.git) registered for path 'qtandroidextras'
    Submodule 'qtbase' (git://code.qt.io/qt/qtbase.git) registered for path 'qtbase'
    Submodule 'qtcanvas3d' (git://code.qt.io/qt/qtcanvas3d.git) registered for path 'qtcanvas3d'
    Submodule 'qtcharts' (git://code.qt.io/qt/qtcharts.git) registered for path 'qtcharts'
    Submodule 'qtconnectivity' (git://code.qt.io/qt/qtconnectivity.git) registered for path 'qtconnectivity'
    Submodule 'qtdatavis3d' (git://code.qt.io/qt/qtdatavis3d.git) registered for path 'qtdatavis3d'
    Submodule 'qtdeclarative' (git://code.qt.io/qt/qtdeclarative.git) registered for path 'qtdeclarative'
    Submodule 'qtdoc' (git://code.qt.io/qt/qtdoc.git) registered for path 'qtdoc'
    Submodule 'qtgamepad' (git://code.qt.io/qt/qtgamepad.git) registered for path 'qtgamepad'
    Submodule 'qtgraphicaleffects' (git://code.qt.io/qt/qtgraphicaleffects.git) registered for path 'qtgraphicaleffects'
    Submodule 'qtimageformats' (git://code.qt.io/qt/qtimageformats.git) registered for path 'qtimageformats'
    Submodule 'qtlocation' (git://code.qt.io/qt/qtlocation.git) registered for path 'qtlocation'
    Submodule 'qtmacextras' (git://code.qt.io/qt/qtmacextras.git) registered for path 'qtmacextras'
    Submodule 'qtmultimedia' (git://code.qt.io/qt/qtmultimedia.git) registered for path 'qtmultimedia'
    Submodule 'qtnetworkauth' (git://code.qt.io/qt/qtnetworkauth.git) registered for path 'qtnetworkauth'
    Submodule 'qtpurchasing' (git://code.qt.io/qt/qtpurchasing.git) registered for path 'qtpurchasing'
    Submodule 'qtqa' (git://code.qt.io/qt/qtqa.git) registered for path 'qtqa'
    Submodule 'qtquickcontrols' (git://code.qt.io/qt/qtquickcontrols.git) registered for path 'qtquickcontrols'
    Submodule 'qtquickcontrols2' (git://code.qt.io/qt/qtquickcontrols2.git) registered for path 'qtquickcontrols2'
    Submodule 'qtremoteobjects' (git://code.qt.io/qt/qtremoteobjects.git) registered for path 'qtremoteobjects'
    Submodule 'qtrepotools' (git://code.qt.io/qt/qtrepotools.git) registered for path 'qtrepotools'
    Submodule 'qtscript' (git://code.qt.io/qt/qtscript.git) registered for path 'qtscript'
    Submodule 'qtscxml' (git://code.qt.io/qt/qtscxml.git) registered for path 'qtscxml'
    Submodule 'qtsensors' (git://code.qt.io/qt/qtsensors.git) registered for path 'qtsensors'
    Submodule 'qtserialbus' (git://code.qt.io/qt/qtserialbus.git) registered for path 'qtserialbus'
    Submodule 'qtserialport' (git://code.qt.io/qt/qtserialport.git) registered for path 'qtserialport'
    Submodule 'qtspeech' (git://code.qt.io/qt/qtspeech.git) registered for path 'qtspeech'
    Submodule 'qtsvg' (git://code.qt.io/qt/qtsvg.git) registered for path 'qtsvg'
    Submodule 'qttools' (git://code.qt.io/qt/qttools.git) registered for path 'qttools'
    Submodule 'qttranslations' (git://code.qt.io/qt/qttranslations.git) registered for path 'qttranslations'
    Submodule 'qtvirtualkeyboard' (git://code.qt.io/qt/qtvirtualkeyboard.git) registered for path 'qtvirtualkeyboard'
    Submodule 'qtwayland' (git://code.qt.io/qt/qtwayland.git) registered for path 'qtwayland'
    Submodule 'qtwebchannel' (git://code.qt.io/qt/qtwebchannel.git) registered for path 'qtwebchannel'
    Submodule 'qtwebengine' (git://code.qt.io/qt/qtwebengine.git) registered for path 'qtwebengine'
    Submodule 'qtwebglplugin' (git://code.qt.io/qt/qtwebglplugin.git) registered for path 'qtwebglplugin'
    Submodule 'qtwebsockets' (git://code.qt.io/qt/qtwebsockets.git) registered for path 'qtwebsockets'
    Submodule 'qtwebview' (git://code.qt.io/qt/qtwebview.git) registered for path 'qtwebview'
    Submodule 'qtwinextras' (git://code.qt.io/qt/qtwinextras.git) registered for path 'qtwinextras'
    Submodule 'qtx11extras' (git://code.qt.io/qt/qtx11extras.git) registered for path 'qtx11extras'
    Submodule 'qtxmlpatterns' (git://code.qt.io/qt/qtxmlpatterns.git) registered for path 'qtxmlpatterns'
    + git config commit.template /home/minhaj/opt/qt5/.commit-template
    + git clone --no-checkout git://code.qt.io/qt/qt3d.git qt3d
    Cloning into 'qt3d'...
    fatal: The remote end hung up unexpectedly
    git clone --no-checkout git://code.qt.io/qt/qt3d.git qt3d exited with status 32768 at ./init-repository line 198.
    	Qt::InitRepository::exe(Qt::InitRepository=HASH(0x1f658b8), "git", "clone", "--no-checkout", "git://code.qt.io/qt/qt3d.git", "qt3d") called at ./init-repository line 534
    	Qt::InitRepository::git_clone_one_submodule(Qt::InitRepository=HASH(0x1f658b8), "qt3d", "qt3d.git", 0) called at ./init-repository line 408
    	Qt::InitRepository::git_clone_all_submodules(Qt::InitRepository=HASH(0x1f658b8), "qt5", 0, "preview", "essential", "addon", "deprecated") called at ./init-repository line 644
    	Qt::InitRepository::run(Qt::InitRepository=HASH(0x1f658b8)) called at ./init-repository line 655
    

    Below are URL's already checked & applied, so don't marked it as duplicate https://bugreports.qt.io/browse/QTBUG-49133

    https://bugreports.qt.io/browse/QTBUG-59753

    https://codereview.qt-project.org/#/c/189744/3/init-repository

    https://bugreports.qt.io/browse/QTBUG-60103


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.