Could not determine java version.

  • Hello and Merry Christmas everyone,

    I'm trying to run a QML and Android test application using Qt 5.7 but got stuck with this issue that is coming up every time i try to run:

    22:18:36: Running steps for project android-test...
    22:18:36: Configuration unchanged, skipping qmake step.
    22:18:36: Starting: "/usr/bin/make" 
    make: Nothing to be done for 'first'.
    22:18:36: The process "/usr/bin/make" exited normally.
    22:18:36: Removing directory /home/guilherme/Desktop/Sandbox/devel/qt/build-android-test-Android_for_armeabi_v7a_GCC_4_9_Qt_5_7_1-Debug/android-build/assets
    22:18:36: Removing directory /home/guilherme/Desktop/Sandbox/devel/qt/build-android-test-Android_for_armeabi_v7a_GCC_4_9_Qt_5_7_1-Debug/android-build/libs
    22:18:36: Starting: "/usr/bin/make" INSTALL_ROOT=/home/guilherme/Desktop/Sandbox/devel/qt/build-android-test-Android_for_armeabi_v7a_GCC_4_9_Qt_5_7_1-Debug/android-build install
    install -m 755 -p /home/guilherme/Desktop/Sandbox/devel/qt/build-android-test-Android_for_armeabi_v7a_GCC_4_9_Qt_5_7_1-Debug/android-build/libs/armeabi-v7a/
    22:18:36: The process "/usr/bin/make" exited normally.
    22:18:36: Starting: "/home/guilherme/Programs/Qt/5.7/android_armv7/bin/androiddeployqt" --input /home/guilherme/Desktop/Sandbox/devel/qt/build-android-test-Android_for_armeabi_v7a_GCC_4_9_Qt_5_7_1-Debug/ --output /home/guilherme/Desktop/Sandbox/devel/qt/build-android-test-Android_for_armeabi_v7a_GCC_4_9_Qt_5_7_1-Debug/android-build --deployment bundled --android-platform android-27 --jdk /usr/lib/jvm/java-9-openjdk-amd64 --gradle
    Generating Android Package
      Input file: /home/guilherme/Desktop/Sandbox/devel/qt/build-android-test-Android_for_armeabi_v7a_GCC_4_9_Qt_5_7_1-Debug/
      Output directory: /home/guilherme/Desktop/Sandbox/devel/qt/build-android-test-Android_for_armeabi_v7a_GCC_4_9_Qt_5_7_1-Debug/android-build/
      Application binary: /home/guilherme/Desktop/Sandbox/devel/qt/build-android-test-Android_for_armeabi_v7a_GCC_4_9_Qt_5_7_1-Debug/
      Android build platform: android-27
      Install to device: No
    FAILURE: Build failed with an exception.
    * What went wrong:
    Could not determine java version from '9-internal'.
    * Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
    Building the android package failed!
      -- For more information, run this command with --verbose.
    22:18:38: The process "/home/guilherme/Programs/Qt/5.7/android_armv7/bin/androiddeployqt" exited with code 14.
    Error while building/deploying project android-test (kit: Android for armeabi-v7a (GCC 4.9, Qt 5.7.1 for Android armv7))
    When executing step "Build Android APK"
    22:18:38: Elapsed time: 00:02.

    SDK, NDK settings under Qt Creator seems to be all good:

    SDK & NDK

    All smooth under Android Studio, as well.

    Already tried downgrading sdk-tools to 25.2.5 based on a stackoverflow answer, but to no avail.

    If anyone had the same problem i would really appreciate if you could give me some guidance.

  • Sorry!
    Just a silly issue solved based on the logs: installed openjdk-8-jdk.
    All ok!

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.