Problem with deployment, windows



  • Hello everybody,
    I followed these steps to deploy 2 applications based on Qt5.8 with QtCreator 4.1.1

    https://forum.qt.io/topic/85375/procedure-entry-point-not-located-when-deploying-qt-mingw-application

    The first application is a graphic interface window and it worked fine.
    The second is a simple console application, and it failled : when I run the exe, I get "Application couldn't propoerly run (0xc000007b) (french translation).
    I don't understand.
    Notice I have some std lib usage in the console application as it was originaly developped on visual studio c++.
    Do I have to replace these std lib usage ?
    Other suggestion ?

    Anyone could help ?
    Thanks.



  • Hi, error 0xc000007b means that your .exe file is 64-bit but it tries to load some 32-bit .dll, or the other way around.

    To see what .dlls, you can try running the app inside Dependency Walker, load the .exe and start it by pressing F7.



  • Hi,
    thanks for your answer,
    here is what I got with Dependency Walker, F7 has no effect.

    File not found in local directory or search path :
    API-MS-WIN-SERVICE-PRIVATE-L1-1-1.DLL
    API-MS-WIN-CORE-PRIVATEPROFILE-L1-1-1.DLL
    API-MS-WIN-CORE-KERNEL32-PRIVATE-L1-1-1.DLL

    Could not find the section that owns the Import Directory :
    LIBGOMP-1.DLL



  • Ok it works !

    Before I ran again windeployqt, I added in the PATH C:\Qt\Tools\mingw530_32\bin;
    where is LIBGOMP-1.DLL

    Thanks for helping !


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.