Upgrade from Qt 4.7.4 (mingw 4.4) to 5.8 (mingw 5.3) on windows



  • Hello.
    I would like to upgrade a project from Qt 4.7.4 (mingw 4.4) to Qt 5.8 (mingw 5.3).
    The OS is Windows 7. The Qt Creator version is 4.4.1.
    The project includes :

    It uses QtWebkit https://github.com/annulen/webkit/releases/tag/qtwebkit-tp5

    The first project was created with Qt 4.7.4 (mingw 4.4) and an old version of Qt Creator.

    My first step was to upgrade to Qt Creator 4.4.1, keeping Qt 4.7.4 (mingw 4.4).
    The project compiles and runs.
    However I have this warning:
    "C:\Qt\mingw\bin\g++.exe" is used by qmake, but "C:\Qt\mingw\bin\mingw32-c++.exe" is configured in the kit.
    Please update your kit or choose a mkspec for qmake that matches your target environment better."
    The kit is defined like this:
    0_1512490826659_Kit Qt 4.7.4.PNG
    0_1512490836621_Qt 4.7.4.PNG
    0_1512490848260_Compilateur Mingw 4.4.PNG

    The second step is to upgrade to Qt 5.8 (mingw 5.3).
    Compilation succeeds. But execution fails directly at the beginning.
    The kit is defined like this:
    0_1512490858656_Kit Qt 5.8.PNG
    0_1512490867770_Qt 5.8.PNG
    0_1512490878101_Compilateur Mingw 5.3.PNG

    Qt and Mingw were installed with Qt Maintenance Tool.

    Perhaps my compiler is not correct?
    Do you have any idea?
    Ask me if you need more infos about merkaartor libs or my .pro.
    Thanks by advance for your advice.



  • @Shikikairo

    It uses QtWebkit https://github.com/annulen/webkit/releases/tag/qtwebkit-tp5

    I'm afraid this has nothing to do with your compiler issues. You probably know a lot more about this than I do, but QtWebKit got dropped by Qt for QtWebEngine at Qt 5.7. This keeps coming up and I'd like to understand: are you able to continue to use QtWebKit because you compile source code from that link, and that still works? Thanks.


  • Qt Champions 2016

    @JNBarchan
    Hi
    WebKits got resurrected
    https://forum.qt.io/topic/76739/webkit-status-2017


  • Qt Champions 2016

    @Shikikairo said in Upgrade from Qt 4.7.4 (mingw 4.4) to 5.8 (mingw 5.3) on windows:

    Compilation succeeds. But execution fails directly at the beginning.

    Have you tried with a break point in main ?
    If it crashes before that, its most likely DLL related.

    If you can compile it in 5.8 its a very good sign and it should be possible to get it to work.



  • Reading different articles I've understood my config is not compatible with QtWebEngine.
    So I've downloaded QtWebKit package "qtwebkit-tp5-qt58-mingw530-x86.zip"
    here.
    I've copied bin, include, lib and mkspecs directories into C:\Qt\5.8\5.8\mingw53_32.
    In my .pro I have

    QT += core gui xml svg network webkit sql printsupport webkitwidgets widgets script
    

    When I use breakpoints I have this warning:
    0_1512562813068_Breakpoint.PNG

    The debugger is "C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x86\cdb.exe".
    I've tried with the debugger "GNU gdb 7.10.1 for MinGW 5.3 32bit", it crashes before the breakpoint in the main.

    I've created an empty Qt widget application with Log4Qt alone. Compilation and execution ok.
    I've added Merkaartor to this project and it crashes.
    I also use libraries: libgdal and libproj for example.


  • Qt Champions 2016

    Hi
    Did you use another mingw than the one included ?
    I never saw that message before :)



  • In my old project using Qt 4.7.4 (mingw 4.4), I needed to download Merkaartor dependencies built for Windows in a git repository:
    0_1512569315546_mingw dependencies.PNG



  • Now I'm trying to find a solution reading "COMPILE.md" file of Merkaartor:
    0_1512570020984_Merkaartor compiling 1.PNG
    0_1512570025986_Merkaartor compiling 2.PNG
    0_1512570031146_Merkaartor compiling 3.PNG
    0_1512570037160_Merkaartor compiling 4.PNG


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.