MSVC-2017x64 - WinRT Run & Console Issues



  • Hello,

    I have a blank Qt Quick2 (5.9.3) project that I want to build for standard MSVC2017-x64 and MSVC2017-UWPx64.
    I am also using CMake as this project will eventually be combined into a larger multi-project CMake based solution.

    I have two problems;

    1. The project is built with the console subsystem. A console window appears when launching the exectuable.
    2. The UWP build has a greyed-out run/debug button forcing me to deploy and test manually.

    Regarding the Console issue
    I have looked online for possible solutions and have come up short.
    The solutions so far have not resolved my issues with the console in both non UWP and UWP builds.
    I can remove the console for the NON-UWP build by adding "WIN32" to add_exectuable command. This breaks the UWP Build ofc.
    (I understand this is more a CMake issue but there must be a simple solution to this).

    Regarding the disabled run/debug buttons for UWP build
    I have tried adding a custom-exectuable to the run config but Qt complains that "This device cannot create new processes".
    Mousing over the run button shows: Cannot Run "MyProject"

    I have tried deleting the .user file also, to no avail.
    If you require any information or screenshots please let me know, AFAIK all the kits are correctly configured, they all build fine.

    Any help is greatly appreciated.
    Thanks



Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.