Update from Qt 5.4.2 to 5.6.3 on Windows7/XP



  • Hi all,

    we have deployed a embedded software solution based on Qt 5.4.2. This software runs on multiple HW/OS.
    The solution is split is 3 main parts:

    • a splashscreen application (using Qt Widgets)
    • a "service" application (using QCoreApplication)
    • a "front end" application (using QML)

    Our software is working in KioskMode, so there is no standard shell. And all works fine with Qt 5.4.2.
    Now we want to upgrade Qt version to last LTS supporting XP ==> 5.6.3 to improve software performances.

    But with Qt 5.6.3 I've got several issues:

    • On Windows7 (Toolchain used VS2013): I've used the Qt "standard" VS2013/32bit build, the software is running but the front end application is "back". To activate the display I have to send "ctrl+alt+del" to got the "logging screeen", the I send "Esc" and the front end application is now visibile!
    • On WindowsXP (Toolchain used VS2012): I had to build my self the Qt from sources (I had also to do it for Qt 5.4.2 so no surprise ;) ). Here the splashscreen application does on display text (the SVG picture is not visible) and the QML application is not show anything.

    To solve the Windows7 / QML issue, I try to used QWindowsWindowFunctions::setHasBorderInFullScreen() as describe in http://doc.qt.io/archives/qt-5.6/windows-issues.html. But this did not change anything :(

    On WindowsXP, I've got following error in QML application:
    QOpenGLShaderProgram: could not create shader program
    QOpenGLShader: could not create shader
    QOpenGLShader: could not create shader
    shader compilation failed: ""
    QOpenGLShaderProgram::uniformLocation( qt_Matrix ): shader program is not linked
    QOpenGLShaderProgram: could not create shader program
    QOpenGLShader: could not create shader
    QOpenGLShader: could not create shader
    shader compilation failed: ""
    QOpenGLShaderProgram::uniformLocation( matrix ): shader program is not linked
    QOpenGLShaderProgram::uniformLocation( color ): shader program is not linked
    QOpenGLShaderProgram::uniformLocation( textureScale ): shader program is not linked
    QOpenGLShaderProgram::uniformLocation( dpr ): shader program is not linked
    ...

    Is some one aware about those issues?
    Is here the right place to post this kind of questions?

    Best regards

    Fabrice


  • Moderators

    @KroMignon said in Update from Qt 5.4.2 to 5.6.3 on Windows7/XP:

    Is some one aware about those issues?

    Probably it is better to check on JIRA if those are known issues.

    @KroMignon said in Update from Qt 5.4.2 to 5.6.3 on Windows7/XP:

    Is here the right place to post this kind of questions?

    Also on JIRA you may find already work arounds or discussions.

    If you do not get feedback within a reasonable time frame, you may want to check with the developer mailing list.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.