Timeout error in QModbusDevice::sendReadRequest on 2nd+ read in QT5.9.2



  • Hi all,
    I'm new in this forum. I'm quiet sure I found a bug in QModbusDevice::sendReadRequest in QT5.9.2 on Windows ( windows7 32bit ) and MinGW. I want to make a bugreport, but I've no idea which project, component or topic this belongs. So can anyone assist me.

    My program worked fine on QT5.8.0 on Windows32 and MinGW with an internal RS485 as well as on a USB-RS485. When moving to a new computer with QT5.9.2 the program only read once then only reported timeout-error on following reads. Closing the program an rerun let it read one time again.

    Installing QT5.8.0 on that computer solved the problem.

    Anyone else encountered this problem?
    Thanks. Henni



  • Hi @Henni,

    From your description it looks like this one: https://bugreports.qt.io/browse/QTBUG-53767

    Otherwise you can create a new report and use "MOD bus" for the Component.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.