WebGL not enabled in WebEngineView on ARM Linux with Desktop OpenGL



  • I'm trying to get WebGL hardware suppport working in WebEngineView. When I point the WebEgnine to here, I get "Hmm, While your browser supports WebGL, it is disabled or unavailable."

    Here's the setup:

    Tegra K1 (ARM)
    Linux
    Qt5.9 built against OpenGL/GLX (not GLES2/EGL)
    Platform supports: OpenGL 4.4.0, GLX 1.4 (NVIDIA drivers )
    

    I've read other posts that suggest passing in --ignore-gpu-blacklist Chromium flag. I've tried to pass this into both the constructor of QApplication, and by setting it in the environment variable QTWEBENGINE_CHROMIUM_FLAGS. In fact, it seems like none of these flags work at all. I've tried passing in --crash-test, which is supposed to immediately crash the browser, but it seems to not work at all, so I'm not even sure if these flags are making it to Chromium.

    I'll say that I've verified that WebGL works with Qt built with GLES 2.0 and EGL enabled on my platform, but unfortunately I have a software dependency that does not support EGL, so everything has to be OpenGL/GLX.

    Are there build options I'm missing when building qtwebengine? I rebuilt it linked against qtbase built against OpenGL/GLX. But other than that are there other build options I'm missing?



  • AFAIK These are command line options and not flags...
    Have you tired passing these config options on the command line instead
    ex.
    MyApp.exe --crash-test
    or
    MyApp.exe --ignore-gpu-blacklist


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.