Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

[Moved] configure prefix



  • Hi
    I want to compile "flightgear":http://wiki.flightgear.org/Building_FlightGear_-_Linux but having the simgear dependency not at default location:

    ./configure --prefix=/path/to/fgInstallation --with-osg=/path/to/osg/installation --enable-osgviewer

    Where would i put the above command line in qtcreator settings?
    Many thanks
    Michael


  • Moderators

    yes, go into Projects->Build steps->qmake [details]

    There is an input field 'Additional arguments' - pu 'em there.

    All that assuming that flightgear is a Qt project.



  • only make but says unrecognized option --prefix. doesn't this belong in qtcreator below make?

    ./configure --prefix=/media/DATA/FGFS/install/fgfs/ --exec-prefix=/media/DATA/FGFS/install/fgfs/ --with-osg=/media/DATA/FGFS/install/OpenSceneGraph --with-simgear=/media/DATA/FGFS/install/simgear --with-plib=/media/DATA/FGFS/install/plib

    Thanks
    Michael



  • There is an "Add build step" button in the same view. If the project doesn't use qmake (I assume it doesn't because it uses configure), you can also remove qmake there.



  • Moved to the tools forums, it's a Qt Creator question, not a Qt issue neither one of installing Qt.


  • Moderators

    I would personally not put the command into the Qt Creator settings at all: You do not want to keep re-running this for each and every build!

    So just run it once from a terminal and then only add the "make" step to Qt Creator. That should work fine.


Log in to reply