Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Using jom in a cmake project on windows



  • I have the "Use jom instead of nmake" checked the General Build&Run settings. It works for qmake projects, but does not seem to work for cmake projects. In the latter case cmake just seems to be launching nmake. The problem with this is, that build time is severely degraded as nmake doesn't seem to take a flag to enable parallel builds. Is there a way this can be resolved?



  • In Options->Build and Run->Kits, after selecting your kit at the top of the options window, the settings will be shown down below. One of those options is 'CMake generator'. Press the 'Change' button for that option and you will be able to select 'NMake Makefiles JOM' as your generator.


Log in to reply